java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Hi there, I know this error may have been solved before but tried implementing the solutions that I've seen but nothing seems to be working for me. I've been stuck on this problem for 2 days now. I was wondering if you guys could help me out. Also, I am new to logstash..

When I type in this command in the terminal: bin/logstash -f logstash_http_puller.conf

I get this output:
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release. WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.jruby.ext.openssl.SecurityHelper (file:/var/folders/1r/mr7dgqyd3sn6682blb8pdrwm0000gn/T/jruby-6104/jruby14033672831858299011jopenssl.jar) to field WARNING: Please consider reporting this to the maintainers of org.jruby.ext.openssl.SecurityHelper WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release Sending Logstash logs to /Users/michaelsantos/Documents/FinalYearProject/ApplicaionInstance/logstash-7.9.3/logs which is now configured via [2020-10-28T19:27:52,082][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.9.3", "jruby.version"=>"jruby (2.5.7) 2020-08-03 9a89c94bcc Java HotSpot(TM) 64-Bit Server VM 13+33 on 13+33 +indy +jit [darwin-x86_64]"} [2020-10-28T19:27:52,526][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified [2020-10-28T19:27:53,978][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/Users/michaelsantos/Documents/FinalYearProject/ApplicaionInstance/logstash-7.9.3/logstash_http_puller.conf"} [2020-10-28T19:27:54,036][ERROR][logstash.config.sourceloader] No configuration found in the configured sources. [2020-10-28T19:27:54,653][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600} [2020-10-28T19:27:59,463][INFO ][logstash.runner ] Logstash shut down. [2020-10-28T19:27:59,494][ERROR][org.logstash.Logstash ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

It is telling you that the file does not exist, or is not readable. Should that "ApplicaionInstance" be "ApplicationInstance"?

I think it's pointing to the wrong file path but I'm not sure how to change it... Oh yes, that's a spelling mistake. Sorry.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.