"java.lang.OutOfMemoryError: Java heap space" Still 337 MB RAM available


(Martin Stabenfeldt) #1

Hi,

This error arrived today after I rebooted my Mac.
It might have been something that OS X has updated since last time, I don't
know that for sure.
I'm running "elasticsearch: stable 1.3.1, HEAD". Installed with Homebrew.

Any suggestions to how I can resolve this problem?

$ ps aux|grep java

martins 13093 100.2 14.1 3810672 1179436 ?? R 2:10PM
15:32.24 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true
-XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -XX:+DisableExplicitGC -Xss200000
-Delasticsearch -Des.foreground=yes
-Des.path.home=/usr/local/Cellar/elasticsearch/1.3.1 -cp
:/usr/local/Cellar/elasticsearch/1.3.1/libexec/elasticsearch-1.3.1.jar:/usr/local/Cellar/elasticsearch/1.3.1/libexec/:/usr/local/Cellar/elasticsearch/1.3.1/libexec/sigar/
-Des.config=/usr/local/Cellar/elasticsearch/1.3.1/config/elasticsearch.yml
org.elasticsearch.bootstrap.Elasticsearch

$ tail -f /usr/local/var/log/elasticsearch/elasticsearch_martins.log

at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:408)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:362)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:181)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:724)
[2014-08-04 14:24:08,057][ERROR][rest.action.support ] failed to send
failure response
java.lang.OutOfMemoryError: Java heap space

I have currently 337 MB RAM free. That should be enough, should it not?

elasticsearch.yml

cluster.name: elasticsearch_martins
path.data: /usr/local/var/elasticsearch/
path.logs: /usr/local/var/log/elasticsearch/
path.plugins: /usr/local/var/lib/elasticsearch/plugins
network.host: 127.0.0.1

Cheers,
Martin Stabenfeldt

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0c3a6d2-2fe3-4c79-91b5-cac73e521cb1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Martin Stabenfeldt) #2

Discovered that /usr/local/var/elasticsearch had grown to 14GB
As it's my develop machine, I did not need the old data and deleted it.

Started ES again and things went back to normal! :slight_smile:

On Monday, August 4, 2014 2:34:49 PM UTC+2, Martin Stabenfeldt wrote:

Hi,

This error arrived today after I rebooted my Mac.
It might have been something that OS X has updated since last time, I
don't know that for sure.
I'm running "elasticsearch: stable 1.3.1, HEAD". Installed with Homebrew.

Any suggestions to how I can resolve this problem?

$ ps aux|grep java

martins 13093 100.2 14.1 3810672 1179436 ?? R 2:10PM
15:32.24 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true
-XX:+UseParNewGC -XX:+UseConcMarkSweepGC
-XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -XX:+DisableExplicitGC -Xss200000
-Delasticsearch -Des.foreground=yes
-Des.path.home=/usr/local/Cellar/elasticsearch/1.3.1 -cp
:/usr/local/Cellar/elasticsearch/1.3.1/libexec/elasticsearch-1.3.1.jar:/usr/local/Cellar/elasticsearch/1.3.1/libexec/:/usr/local/Cellar/elasticsearch/1.3.1/libexec/sigar/
-Des.config=/usr/local/Cellar/elasticsearch/1.3.1/config/elasticsearch.yml
org.elasticsearch.bootstrap.Elasticsearch

$ tail -f /usr/local/var/log/elasticsearch/elasticsearch_martins.log

at
org.elasticsearch.indices.cluster.IndicesClusterStateService.processMapping(IndicesClusterStateService.java:408)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyMappings(IndicesClusterStateService.java:362)
at
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:181)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:444)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:724)
[2014-08-04 14:24:08,057][ERROR][rest.action.support ] failed to
send failure response
java.lang.OutOfMemoryError: Java heap space

I have currently 337 MB RAM free. That should be enough, should it not?

elasticsearch.yml

cluster.name: elasticsearch_martins
path.data: /usr/local/var/elasticsearch/
path.logs: /usr/local/var/log/elasticsearch/
path.plugins: /usr/local/var/lib/elasticsearch/plugins
network.host: 127.0.0.1

Cheers,
Martin Stabenfeldt

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/882b0734-8e80-4b01-9bff-720e248be838%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #3

You have 1g heap only configured for Elasticsearch. You should increase it.

Or try to disable bloom filter loading, this might help when recovering
from large indices with unique terms. It will be disabled by default in ES
1.4

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/index-modules-codec.html#bloom-postings

Jörg

On Mon, Aug 4, 2014 at 2:41 PM, Martin Stabenfeldt martin@stabenfeldt.net
wrote:

Discovered that /usr/local/var/elasticsearch had grown to 14GB
As it's my develop machine, I did not need the old data and deleted it.

Started ES again and things went back to normal! :slight_smile:

On Monday, August 4, 2014 2:34:49 PM UTC+2, Martin Stabenfeldt wrote:

Hi,

This error arrived today after I rebooted my Mac.
It might have been something that OS X has updated since last time, I
don't know that for sure.
I'm running "elasticsearch: stable 1.3.1, HEAD". Installed with Homebrew.

Any suggestions to how I can resolve this problem?

$ ps aux|grep java

martins 13093 100.2 14.1 3810672 1179436 ?? R 2:10PM
15:32.24 /usr/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true
-XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:
CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly
-XX:+HeapDumpOnOutOfMemoryError -XX:+DisableExplicitGC -Xss200000
-Delasticsearch -Des.foreground=yes -Des.path.home=/usr/local/Cellar/elasticsearch/1.3.1
-cp :/usr/local/Cellar/elasticsearch/1.3.1/libexec/
elasticsearch-1.3.1.jar:/usr/local/Cellar/elasticsearch/1.
3.1/libexec/:/usr/local/Cellar/elasticsearch/1.3.1/libexec/sigar/
-Des.config=/usr/local/Cellar/elasticsearch/1.3.1/config/elasticsearch.yml
org.elasticsearch.bootstrap.Elasticsearch

$ tail -f /usr/local/var/log/elasticsearch/elasticsearch_martins.log

at org.elasticsearch.indices.cluster.IndicesClusterStateService.
processMapping(IndicesClusterStateService.java:408)
at org.elasticsearch.indices.cluster.IndicesClusterStateService.
applyMappings(IndicesClusterStateService.java:362)
at org.elasticsearch.indices.cluster.IndicesClusterStateService.
clusterChanged(IndicesClusterStateService.java:181)
at org.elasticsearch.cluster.service.InternalClusterService$
UpdateTask.run(InternalClusterService.java:444)
at org.elasticsearch.common.util.concurrent.
PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(
PrioritizedEsThreadPoolExecutor.java:153)
at java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:724)
[2014-08-04 14:24:08,057][ERROR][rest.action.support ] failed to
send failure response
java.lang.OutOfMemoryError: Java heap space

I have currently 337 MB RAM free. That should be enough, should it not?

elasticsearch.yml

cluster.name: elasticsearch_martins
path.data: /usr/local/var/elasticsearch/
path.logs: /usr/local/var/log/elasticsearch/
path.plugins: /usr/local/var/lib/elasticsearch/plugins
network.host: 127.0.0.1

Cheers,
Martin Stabenfeldt

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/882b0734-8e80-4b01-9bff-720e248be838%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/882b0734-8e80-4b01-9bff-720e248be838%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHF09f9Pte0s%2BUCRKesTKanpVeNf6oS50-GgJM17tAciQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4