Jdbc postgres logstash Pipeline error {:pipeline_id=>"main",

Hi,

when i tried to execute my file logstash conf

input {
    jdbc {
        jdbc_connection_string => "jdbc:postgresql://localhost:5432"
        jdbc_user => "postgres"
        jdbc_password => "1234"
        jdbc_driver_class => "org.postgresql.Driver"
        schedule => "0 * * * *" # cronjob schedule format (see "Helpful Links")
        statement => "SELECT * FROM public.E-ANOMAL" # the PG command for retrieving the documents IMPORTANT: no semicolon!
        jdbc_paging_enabled => "true"
        jdbc_page_size => "300"
        tracking_column => "id"
	     tracking_column_type => numeric

    }
}

output {
  elasticsearch {
    hosts => ["http://localhost:9200"]
    data_stream => true
    data_stream_type => "microservice"
  }    
 }
}
**here is the pepline error that I can't solve**

"Using bundled JDK: ."
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logs which is now configured via log4j2.properties
[2022-07-22T10:43:22,493][INFO ][logstash.runner          ] Log4j configuration path used is: C:\Users\Lenovo\Desktop\ELK\logstash-8.1.0\config\log4j2.properties
[2022-07-22T10:43:22,514][WARN ][logstash.runner          ] The use of JAVA_HOME has been deprecated. Logstash 8.0 and later ignores JAVA_HOME and uses the bundled JDK. Running Logstash with the bundled JDK is recommended. The bundled JDK has been verified to work with each specific version of Logstash, and generally provides best performance and reliability. If you have compelling reasons for using your own JDK (organizational-specific compliance requirements, for example), you can configure LS_JAVA_HOME to use that version instead.
[2022-07-22T10:43:22,517][INFO ][logstash.runner          ] Starting Logstash {"logstash.version"=>"8.1.0", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.13+8 on 11.0.13+8 +indy +jit [mswin32-x86_64]"}
[2022-07-22T10:43:22,523][INFO ][logstash.runner          ] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -Djruby.regexp.interruptible=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]
[2022-07-22T10:43:22,911][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2022-07-22T10:43:27,499][INFO ][logstash.agent           ] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}
[2022-07-22T10:43:30,239][INFO ][org.reflections.Reflections] Reflections took 590 ms to scan 1 urls, producing 120 keys and 417 values
[2022-07-22T10:43:32,534][INFO ][logstash.javapipeline    ] Pipeline `main` is configured with `pipeline.ecs_compatibility: v8` setting. All plugins in this pipeline will default to `ecs_compatibility => v8` unless explicitly configured otherwise.
[2022-07-22T10:43:32,732][INFO ][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//localhost:9200"]}
[2022-07-22T10:43:33,571][INFO ][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://localhost:9200/]}}
[2022-07-22T10:43:34,082][WARN ][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=>"http://localhost:9200/"}
[2022-07-22T10:43:34,114][INFO ][logstash.outputs.elasticsearch][main] Elasticsearch version determined (8.1.0) {:es_version=>8}
[2022-07-22T10:43:34,119][WARN ][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es_version=>8}
[2022-07-22T10:43:34,247][INFO ][logstash.outputs.elasticsearch][main] Config is not compliant with data streams. `data_stream => auto` resolved to `false`
[2022-07-22T10:43:34,248][INFO ][logstash.outputs.elasticsearch][main] Config is not compliant with data streams. `data_stream => auto` resolved to `false`
[2022-07-22T10:43:34,261][WARN ][logstash.outputs.elasticsearch][main] Elasticsearch Output configured with `ecs_compatibility => v8`, which resolved to an UNRELEASED preview of version 8.0.0 of the Elastic Common Schema. Once ECS v8 and an updated release of this plugin are publicly available, you will need to update this plugin to resolve this warning.
[2022-07-22T10:43:34,421][INFO ][logstash.outputs.elasticsearch][main] Using a default mapping template {:es_version=>8, :ecs_compatibility=>:v8}
[2022-07-22T10:43:34,541][INFO ][logstash.javapipeline    ][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>4, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>500, "pipeline.sources"=>["C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/conf.conf"], :thread=>"#<Thread:0x53b8d620 run>"}
[2022-07-22T10:43:36,333][INFO ][logstash.javapipeline    ][main] Pipeline Java execution initialization time {"seconds"=>1.71}
[2022-07-22T10:43:37,257][ERROR][logstash.javapipeline    ][main] Pipeline error {:pipeline_id=>"main", :exception=>#<LogStash::ConfigurationError: Must set :tracking_column if :use_column_value is true.>, :backtrace=>["C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.2.2/lib/logstash/inputs/jdbc.rb:244:in `register'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/vendor/bundle/jruby/2.5.0/gems/logstash-mixin-ecs_compatibility_support-1.3.0-java/lib/logstash/plugin_mixins/ecs_compatibility_support/target_check.rb:48:in `register'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:232:in `block in register_plugins'", "org/jruby/RubyArray.java:1821:in `each'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:231:in `register_plugins'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:390:in `start_inputs'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:315:in `start_workers'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:189:in `run'", "C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/logstash-core/lib/logstash/java_pipeline.rb:141:in `block in start'"], "pipeline.sources"=>["C:/Users/Lenovo/Desktop/ELK/logstash-8.1.0/conf.conf"], :thread=>"#<Thread:0x53b8d620 run>"}
[2022-07-22T10:43:37,264][INFO ][logstash.javapipeline    ][main] Pipeline terminated {"pipeline.id"=>"main"}
[2022-07-22T10:43:37,304][ERROR][logstash.agent           ] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[2022-07-22T10:43:37,438][INFO ][logstash.runner          ] Logstash shut down.
[2022-07-22T10:43:37,456][FATAL][org.logstash.Logstash    ] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby.jar:?]
        at C_3a_.Users.Lenovo.Desktop.ELK.logstash_minus_8_dot_1_dot_0.lib.bootstrap.environment.<main>(C:\Users\Lenovo\Desktop\ELK\logstash-8.1.0\lib\bootstrap\environment.rb:94) ~[?:?]