JsonParseException: Illegal unquoted character ((CTRL-CHAR, code 9)): has to be escaped

Hi All,

I'm getting these exceptions when indexing user comments

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Illegal unquoted character ((CTRL-CHAR, code 9)): has to be escaped using
backslash to be included in string value

  • at [Source: [B@3c4ecbf; line: 1, column: 3033785]*

When indexing this

value : "I do not know about an "industry l
eader." I bank"

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Unexpected character ('i' (code 105)): was expecting comma to separate
OBJECT entries

  • at [Source: [B@2112b320; line: 1, column: 1234]*

I also found this at http://jira.codehaus.org/browse/JACKSON-208

How do I handle special characters like this ? Should I be handling this
while I'm indexing if yes ? Any tips ?

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

you have to provide valid JSON to elasticsearch in order to get data
indexed.
This link should help in order to find out what kind of data you have to
escape

--Alex

On Fri, Jun 14, 2013 at 5:40 AM, Abhishek Andhavarapu <abhishek376@gmail.com

wrote:

Hi All,

I'm getting these exceptions when indexing user comments

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Illegal unquoted character ((CTRL-CHAR, code 9)): has to be escaped using
backslash to be included in string value

  • at [Source: [B@3c4ecbf; line: 1, column: 3033785]*

When indexing this

value : "I do not know about an "industry l
eader." I bank"

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Unexpected character ('i' (code 105)): was expecting comma to separate
OBJECT entries

  • at [Source: [B@2112b320; line: 1, column: 1234]*

I also found this at http://jira.codehaus.org/browse/JACKSON-208

How do I handle special characters like this ? Should I be handling this
while I'm indexing if yes ? Any tips ?

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks Alex. I'm was curious as ES is based on text search if there was a
better way to handle this. So will have to check these while inserting the
data.

On Sun, Jun 16, 2013 at 11:29 AM, Alexander Reelsen alr@spinscale.dewrote:

Hey,

you have to provide valid JSON to elasticsearch in order to get data
indexed.
This link should help in order to find out what kind of data you have to
escape

http://stackoverflow.com/questions/983451/where-can-i-find-a-list-of-escape-characters-required-for-my-json-ajax-return-ty

--Alex

On Fri, Jun 14, 2013 at 5:40 AM, Abhishek Andhavarapu <
abhishek376@gmail.com> wrote:

Hi All,

I'm getting these exceptions when indexing user comments

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Illegal unquoted character ((CTRL-CHAR, code 9)): has to be escaped using
backslash to be included in string value

  • at [Source: [B@3c4ecbf; line: 1, column: 3033785]*

When indexing this

value : "I do not know about an "industry l
eader." I bank"

Caused by: org.elasticsearch.common.jackson.core.JsonParseException:
Unexpected character ('i' (code 105)): was expecting comma to separate
OBJECT entries

  • at [Source: [B@2112b320; line: 1, column: 1234]*

I also found this at http://jira.codehaus.org/browse/JACKSON-208

How do I handle special characters like this ? Should I be handling this
while I'm indexing if yes ? Any tips ?

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/k9ys6XqLE6U/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.