Jvm.options missing while installing elasticsearch-oss

Hi fellows,

  • No docker version involved here
  • Ubuntu 16.04.7 LTS
  • v7.9.1
  • OpenJDK 11.0.5

Yesterday I tried to switch from ELK Basic stack to OSS stack in order to use OpenDistro.
I removed elasticsearch, kibana and logstash from my ubuntu install. Purged dependencies.

Then I installed elasticsearch-oss=7.9.1 as required for OpenDistro by using wget and dpkg, and I'm now unable to start elasticsearch because of a missing file: /etc/elasticsearch/jvm.options

I flushed this install and tried to install again with apt repository. Same issue.

The exact error is:

Starting Elasticsearch...
Exception in thread "main" java.nio.file.NoSuchFileException: /etc/elasticsearch/jvm.options

Could you please guide me on how can I fix this ?


Not sure but may be you should ask for help in this project forum?

I don't know, I could ask on OpenDistro forum too.

The strange thing is that basic install of Elasticsearch don't need/create a jvm.options file neither on that folder, and no error is displayed.

I have no idea. Not sure what is required to replace the standard distribution with the oss one.
If you purged everything, I guess this should work OOTB.

May be there are some remaining files somewhere?

I did check on /etc/elasticsearch and /usr/share/elasticsearch, not here anymore after a apt autoremove.

I have no more clue. I'll try an older version of elasticsearch-oss and let see

I guess you followed this guide?


wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-7.9.3-amd64.deb
wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-7.9.3-amd64.deb.sha512
shasum -a 512 -c elasticsearch-oss-7.9.3-amd64.deb.sha512 
sudo dpkg -i elasticsearch-oss-7.9.3-amd64.deb


Exactly, just I changed to 7.9.1 version.

I used locate to locate (wow) the remaining files, and deleted them, but don't think the remaining one would cause a problem.
I'll try again.

Thx dadoonet for you investigation

Ok, I have great news !

I finally succeeded to start elasticsearch-oss and even Kibana too !
I removed every file containing "elastic" in its name :stuck_out_tongue: and installed it with deb package.

Thanks @dadoonet for you patience :ok_hand:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.