Kafka-input plugin issue


#1

I am trying to use kafka-input plugin with my elk image. I have created a docker iamge based on sebp/elk and add the following line in docker file to install kafka-input plugin.

RUN gosu logstash bin/logstash-plugin install logstash-input-kafka

My kafka input config file is
input {
kafka {
topic_id => "elk"
bootstrap_servers => "xxx.xx.xxx.xxx:9241,xxx.xx.xxx.xxx::9331,xxx.xx.xxx.xxx:9582"
type => "kafka-input"
}
}

After starting the container, I am getting following error:

"Unknown setting 'bootstrap_servers' for kafka", :level=>:error

Any suggestion or help ?


(Magnus Bäck) #2

Have you consulted the documentation for your version of the plugin? You're not saying which version of Logstash so I'm going to assume 2.4, and there's no bootstrap_servers option available there.


#3

I have installed plugin from this link
here and logstash version is 2.4


#4

It would be great if you guide or suggest me to follow any document for installation of kafka input along with elk image?


(Magnus Bäck) #5

I'm not very familiar with the kafka plugins. I suggest you start by studying the Logstash 2.4 documentation. Maybe you can just remove the bootstrap_servers option? Or maybe it has another name in 2.4? Or perhaps you can upgrade to 5.0?


#6

Thanks for your reply. I will try to upgrade to 5.0 and will let you know.


#7

How you config kafka input ,I am faced the same issue
and my logstash version is 5.3, when I start my logstash and nothing hapend, even if i set stdout to console,it does not show anything from kafka data


(KMG) #8

this may help you.