Kibana@5.5.0 source npm run test


(Xiaopeng Zhang) #1

after i follow the CONTRIBUTING.md ,and i use this bath : npm run test .I got some error
[root@zk1 kibana]# npm run test

kibana@5.5.0 test /home/ftpadmin/data/kibana
grunt test

Running "test" task

Running "eslint:source" (eslint) task

Running "licenses" task
Fatal error: Non-conforming licenses:
ua-parser-js
version: 0.7.14
all licenses: (GPL-2.0 OR MIT)
invalid licenses: (GPL-2.0 OR MIT)
path: node_modules/ua-parser-js

npm ERR! Linux 3.10.0-514.26.2.el7.x86_64
npm ERR! argv "/root/.nvm/versions/node/v6.10.2/bin/node" "/root/.nvm/versions/node/v6.10.2/bin/npm" "run" "test"
npm ERR! node v6.10.2
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE
npm ERR! kibana@5.5.0 test: grunt test
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the kibana@5.5.0 test script 'grunt test'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the kibana package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! grunt test
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs kibana
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls kibana
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ftpadmin/data/kibana/npm-debug.log
Does anybody have some suggestion? please


(David Snider (Kibana Design)) #2

@LeeDr might be able to help you here. I assume you ran npm install and didn't run into any errors?


(Xiaopeng Zhang) #3

when i use npm install
[root@zk1 kibana]# npm install
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN grunt-angular-translate@0.3.0 requires a peer of grunt@~0.4.0 but none was installed.
and then i use npm i :
[root@zk1 kibana]# npm i
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN grunt-angular-translate@0.3.0 requires a peer of grunt@~0.4.0 but none was installed.
it's same
if i need npm install again?? or I just go to the ua-parser-js and download it


(Xiaopeng Zhang) #4

hey ,i found something ,in the package.json
it tell it need ua-parser-js@0.7.13
but the error is 0.7.14 ,Is it a version error?

I'm sorry for my bad English


(Xiaopeng Zhang) #5

emmmmm.
i solve it by use the 0.7.13 replace 0.7.14.maybe it's beacuse i'm in china and the net is not well to use npm install so that leads to some problems
thank you for your seggustion last nignt.
sorry for my bad english again


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.