Kibana 5 Index Patterns: Why some fields are unchecked for Searchable


I am using Kibana 5.1

In Index Patterns,for topbeat-* index why some fields are not searchable ?

In Visualization section, whichever chart I create, all the unchecked fields under Searchable column do not appear. ?

What I understood is that on non-searchable fields you cannot create visualizations.
All the non-searchable fields, I am able to see in Discover section.
How can I make these fields searchable ?
Why fields are made searchable or not searchable?

Hi there, that's a really good question, and to be honest I'm not sure of the answer. Would you mind re-posting it in the Beats forum?

Also, it sounds like you may already know this, but you can select the gear icon in the side bar in Discover, and uncheck the "Hide missing fields" checkbox to see additional fields.


Thanks for your response.

I am not experiencing any missing fields, in the Discover tab. I think my post was not clear enough. I did a repost, you can checkout here:Fields in Kibana 5 are non-searchable and non-aggregatable

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.