Kibana 6 Login is currently disabled


(Zeeshan Alam) #1

I am trying elastic 6 and elastic is running fine. But Kibana Login page is disabled. I didn't found anything in the kibana logs to resolve this issue.

My Kibana config:

 server.port: 5601
 server.host: myhost
 server.maxPayloadBytes: 10485760
 elasticsearch.url: http://myhost:9200
 elasticsearch.requestTimeout: 180000
 kibana.index: .kibana
 logging.dest: /apps/elk/logs/kibana.log
 elasticsearch.password: <password for user kibana>
 xpack.security.encryptionKey: 1b4bd002872bffba4cec94bea6000537
 xpack.security.sessionTimeout: 600000

/_cluster/health?pretty

{
  "cluster_name" : "ei-elk6",
  "status" : "yellow",
  "timed_out" : false,
  "number_of_nodes" : 1,
  "number_of_data_nodes" : 1,
  "active_primary_shards" : 6,
  "active_shards" : 6,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 5,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 54.54545454545454
}

(Kilian Ries) #2

Having exact the same problem ... any solution here?


(Tim Vernum) #3

Can you provide whatever logs you do have?
That's the most useful information.

My guess is that Kibana cannot connect to the ES cluster.
Are you running X-Pack with security enabled? If so, did you set a password for the kibana user, and add it to kibana.yml?
See: https://www.elastic.co/guide/en/x-pack/6.0/setting-up-authentication.html#set-built-in-user-passwords


(Kilian Ries) #4

Setting xpack.security.enabled: false in elasticsearch.yml and kibana.yml fixed it temporarily for me


(Magnus Kessler) #5

Hi Zeeshan,

Please check if configuring elasticsearch.username in kibana.yml fixes the issue for you. Previous kibana versions would still enable the login screen if this wasn't configured, but with the new requirement to set your own elasticsearch passwords, it appears to be necessary to configure this setting explicitly now.


(Colin Leavett Brown) #6

I am having the same issue. Installed elk 6.0 from the yum repository on Centos7. With no User Authentication, cluster worked fine. Added user authentication by using the "/usr/share/xxx/bin/xxx-plugin install x-pack" (where "xxx" is elasticsearch (e), kibana (k), or logstash (l)) utilities to add x-pack on each of the components. Then spawned "/usr/share/elasticsearch/bin/x-pack/setup-passwords interactive' from an expect script to set specific passwords for e, l, k. The /etc/kibana/kibana.yaml contains:

  • elasticsearch.username: "kibana"
  • elasticsearch.password: "xxxx"
    and /etc/logstash.logstash.yml contains:
  • cloud.auth: logstash:yyyyy
    The kibana URL now displays "Login is currently disabled. Administrators should consult the Kibana logs for more details.".

(Tim Vernum) #7

Please check the Kibana logs.
If you need help analysing them, then please post the content of those logs.

This is an issue with Kibana connecting to Elasticsearch, the only way to make progress on it, is to see the log files.


(Colin Leavett Brown) #8

Thanks Tim. I have it working now (manual intervention). I am using Ansible to install the server, and just prior to running "/usr/share/elasticsearch/bin/x-pack/setup-passwords interactive" in the expect script, all three elk services are restarted. The log from the expect script shows "ERROR: Failed to connect to elasticsearch at http://10.200.200.225:9200/_xpack/security/_authenticate?pretty. Is the URL correct and elasticsearch running?". I suspect elasticsearch is still initializing and so I have placed a wait_for before the invocation of the expect script and, though i haven't tested a complete re-install, I'm sure this will solve the problem.


(Pratiksha Tewary) #9

This worked for me. Thanks!


#10

Hi,
I have the same problem.
After installing x-pack I get the same log message repeatedly and the login form is disabled.

  log   [16:48:48.147] [warning][license][xpack] License information from the X-
Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [se
curity_exception] missing authentication token for REST request [/_xpack], with
{ header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } ::
{"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"ty
pe\":\"security_exception\",\"reason\":\"missing authentication token for REST r
equest [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\
\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missi
ng authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authentic
ate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}",
"wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}

Can anyone help?
Thanks


(David Pilato) #11

You should better open your own thread and give more details such as the version you are using.
Also check the docs.


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.