Kibana 7.1.1 throws Fatal AssertionError by starting

i've tried to deploy the elk-stack 7.1.1 but kibana does not starts and throws an exeption.

 FATAL  AssertionError [ERR_ASSERTION]: New route /plugins/de.dimdi.util.monitoring.elk:dimdi-elk:jar:7.1.1-SNAPSHOT/{path*} conflicts with existing /plugins/de.dimdi.util.monitoring.elk:dimdi-elk:jar:7.1.1-SNAPSHOT/{path*}

And this is the content of the kibana log file.

{"type":"log","@timestamp":"2019-05-31T08:27:25Z","tags":["fatal","root"],"pid":20753,"message":"{ AssertionError [ERR_ASSERTION]: New route /plugins/de.dimdi.util.monitoring.e
lk:dimdi-elk:jar:7.1.1-SNAPSHOT/{path*} conflicts with existing /plugins/de.dimdi.util.monitoring.elk:dimdi-elk:jar:7.1.1-SNAPSHOT/{path*}\n    at new AssertionError (internal/
assert.js:269:11)\n    at Object.exports.assert (/home/nana/elk/kibana-7.1.1-linux-x86_64/node_modules/hoek/lib/index.js:736:11)\n    at module.exports.internals.Segment.intern
als.Segment.add (/home/nana/elk/kibana-7.1.1-linux-x86_64/node_modules/call/lib/segment.js:67:14)\n    at module.exports.internals.Segment.internals.Segment.add (/home/nana/elk
/kibana-7.1.1-linux-x86_64/node_modules/call/lib/segment.js:61:40)\n    at module.exports.internals.Segment.internals.Segment.add (/home/nana/elk/kibana-7.1.1-linux-x86_64/node
_modules/call/lib/segment.js:61:40)\n    at exports.Router.internals.Router.internals.Router.add (/home/nana/elk/kibana-7.1.1-linux-x86_64/node_modules/call/lib/index.js:63:26)
\n    at internals.Server._addRoute (/home/nana/elk/kibana-7.1.1-linux-x86_64/node_modules/hapi/lib/server.js:467:46)\n    at internals.Server.route (/home/nana/elk/kibana-7.1.
1-linux-x86_64/node_modules/hapi/lib/server.js:456:22)\n    at internals.Server.exposeStaticDir (/home/nana/elk/kibana-7.1.1-linux-x86_64/src/legacy/server/http/index.js:62:10)
\n    at Object.register (/home/nana/elk/kibana-7.1.1-linux-x86_64/src/legacy/server/plugins/lib/plugin.js:62:16)\n    at internals.Server.register (/home/nana/elk/kibana-7.1.1
-linux-x86_64/node_modules/hapi/lib/server.js:431:35)\n    at Plugin.init (/home/nana/elk/kibana-7.1.1-linux-x86_64/src/legacy/server/plugins/lib/plugin.js:75:28)\n    at Plugi
n.init (/home/nana/elk/kibana-7.1.1-linux-x86_64/node_modules/lodash/index.js:7407:25)\n    at callPluginHook (/home/nana/elk/kibana-7.1.1-linux-x86_64/src/legacy/server/plugin
s/lib/call_plugin_hook.js:37:25)\n  generatedMessage: false,\n  name: 'AssertionError [ERR_ASSERTION]',\n  code: 'ERR_ASSERTION',\n  actual: false,\n  expected: true,\n  operat
or: '==' }"}

i have the elk-stack 5.1.1 that runs with the same configuration.
no authentication, no x-pack. only the standard configuration.

Can anyone help me?


Hi Nana, have you installed some custom plugins inside of src/plugins? If so, is it possible that you have more than one plugin installed with the same id? This is a bit of a guess, but the code which throws the error you noted does a check of all plugins when they initialize, so it seems the most likely culprit.

Hi cjcenizal, i have not installed any custom plugins.
i have only unzipped the files and set my configurations.
i run the elk-stack 5.1.1 with the same configuration.
here is my kibana configuration :
server.port: {kibana.http.port} "{}" "{}" elasticsearch.hosts: ["http://{}:{elasticsearch.http.port}"] logging.dest: "{env.vars.elk.home}/kibana.out"
logging.quiet: true

thank you for your reply. Nana

Hi Nana, unfortunately I can't reproduce your error. Could you try using a new download, fresh install, with the default settings and see if that fixes your problem? If so, can you try introducing your custom settings one by one until you identify which one causes the error you're seeing?

hi, thank you for your advice. i setted rights for all files with chmod -R +x kibana/*.
i setted now only rights when needed and i can run it without errors :slight_smile:


That's great to hear! Thanks so much for sharing your solution.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.