Kibana and elasticsearch status is active , i can access elasticsearch via browser but kibana is giving error

I installed kibana and elasticsearch on google instance, elasticsearch is working fine.
curl -X GET "10.128.0.26:9200/"
{
"name" : "node-1",
"cluster_name" : "ElasticsearchStaging",
"cluster_uuid" : "r-A1o-coQlWUWeoXIFa5gw",
"version" : {
"number" : "7.3.0",
"build_flavor" : "default",
"build_type" : "deb",
"build_hash" : "de777fa",
"build_date" : "2019-07-24T18:30:11.767338Z",
"build_snapshot" : false,
"lucene_version" : "8.1.0",
"minimum_wire_compatibility_version" : "6.8.0",
"minimum_index_compatibility_version" : "6.0.0-beta1"
},
"tagline" : "You Know, for Search"
}

curl -X GET "10.128.0.26:5601/"
Kibana server is not ready yet

kibana/log file:

07T10:17:41Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:41Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:43Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:43Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:44Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:44Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:44Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:46Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:46Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:47Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:47Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:47Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:48Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:48Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:50Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:50Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:50Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:51Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:51Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:53Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:53Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","data"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","data"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["license","warning","xpack"],"pid":6590,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluation from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: No Living connections"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:56Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}
07T10:17:56Z","tags":["warning","task_manager"],"pid":6590,"message":"PollError No Living connections"}
07T10:17:58Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"Unable to revive connection: http://0.0.0.0:9200/"}
07T10:17:58Z","tags":["warning","elasticsearch","admin"],"pid":6590,"message":"No living connections"}

kibana.yml file:

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601
# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "10.128.0.26"
# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""
# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false
# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576
# The Kibana server's name.  This is used for display purposes.
server.name: "ironman"
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://0.0.0.0:9200"]
# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
elasticsearch.preserveHost: true
# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
kibana.index: ".kibana"

also I tried ./bin/kibana
this is the message i am getting.
Kibana should not be run as root. Use --allow-root to continue.

after following instruction
./bin/kibana --allow-root

  log   [09:53:13.146] [fatal][root] Error: Port 5601 is already in use. Another instance of Kibana may be running!
    at Root.shutdown (/usr/share/kibana/src/core/server/root/index.js:67:18)
    at Root.setup (/usr/share/kibana/src/core/server/root/index.js:46:18)
    at process._tickCallback (internal/process/next_tick.js:68:7)
    at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)
    at startup (internal/bootstrap/node.js:283:19)
    at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)
 FATAL  Error: Port 5601 is already in use. Another instance of Kibana may be running!

Thanks

It looks like kibana can't connect to your elasticsearch instance. It looks like your configuration for elasticsearch.hosts: ["http://0.0.0.0:9200"] is pointing to a local address instead of the IP you said elasticsearch is located at.

Thanks for the reply, can please elaborate a little bit what should i do now?
should i change the ip?

Yes, does that solve the issue?

No , i changed the
elasticsearch.host: ["http://internal_ip:9200"]
but still its not working.
What else can i try ??

Just to confirm, you previously said the IP address of elasticsearch is 10.128.0.26:9200- did you SSH into your Kibana server and verify that that server can access elasticsearch? It sounds like you are having networking issues, and I don't think I can help with those more than I already have.

Thank you for being with me and replying me.
Can you tell me how to SSH into kibana server, i know its silly question but i am very new to this networking thing.

I notice that you set elasticsearch.host, but the config name is elasticsearch.hosts. You can see all the config options here: https://www.elastic.co/guide/en/kibana/current/settings.html

If you're not very familiar with ssh, I think it's out of scope of what I was trying to ask. I was trying to verify that your Kibana host can talk to your Elasticsearch cluster, but if you can access it from your local machine that is probably fine.

sorry i think there is some sort of misunderstanding my config name is elasticsearch.hosts: . No i don't think my kibana host can talk to elasticsearch cluster that's why i am getting an error message when i hit curl -X GET "10.128.0.26:5601/"
msg: Kibana server is not ready yet . Another important information that i mentioned is i installed it on google cloud instance and ultimately i want to access kibana and elasticsearch from my machine my local browser , and i succeed with elasticsearch i can access elasticsearch from my browser using external ip of google instance , but facing trouble with kibana.
Thanks.

Based on the information you've given me, I'm suspicious of the IP addresses you've told me you're using- they are all local network addresses instead of public internet addresses. I would recommend sshing into your cloud instance and running the same curl commands you've told me already to verify network connectivity. If your instance has a public and fixed IP, you could use that. Alternatively, if it only has a private IP, then I'm not sure how you are able to access it from your local machine. I am not going to be able to help any more on this issue unless you can clarify the networking setup more.

Can you tell me how to generate log file in kibana??

You have already shown me a kibana log- can you do that again?

Like I said above, unless you are able to clarify the setup of your network I will not be able to help you more.

Sir i already tell you everything, i tell you internal as well as external ip of the instance i share log i share yml file, i mean is there anything else? and what is this setup of instance can you please elaborate , what this thing contains?

Since the IP address is a private one, you might need to create an SSH tunnel from your workstation to your GCP host in order to access it.

This suggestion i got, but didn't get it, can you help me out with this. Do you think its right ?