Kibana configuration and cookie based authentication


(Booker Bense) #1

I'm attempting to share a dashboard with the rest of my group and I'm
running into problems where kibana
can not access the es proxy.

The proxy is behind a cookie based authentication system.

Kibana complains that it can't find _nodes

It is configured to use

elasticsearch: "https://server.my.domain:443/es"

However, from Chrome and other browsers, I can access es just fine and in
particular this works.

https://server.my.domain/es/_nodes

My guess is that somehow I need to get kibana to forward the appropriate
cookies. I've tried changing the
line to

elasticsearch: { server:"https://server.my.domain:443/es",
with-credentials : true }

but that did not help. I looked at the logs on the elasticsearch proxy host
and it appears that
kibana is not even querying it. Any suggestion about where to start looking
would be appreciated.

thanks,

  • Booker C. Bense

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/81ca6a34-d175-4ac1-9a87-f8841f419453%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Booker Bense) #2

I've just discovered the cookie is HttpOnly, so that is likely the
fundamental problem.

  • Booker C. Bense

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8b473bb7-d71a-4245-9b41-db7be0e5758d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3