Kibana crashes with default installation with FreeBSD


#1

Hello all,

There appears to be an issue and I didn't know if anybody had any experience with Kibana on FreeBSD.

Elasticsearch seems to install just fine after using the instructions with the package installer, but apparently even after being able to get a curl response from elastic. Also, setup the kibana.yml file with the only option added was "elasticsearch.url: http://localhost:9200". It appears to crash everytime I start the service after doing the first onestart.

Any help would be great.

Thanks all! :smiley:


(Mark Walkom) #2

Technically we don't support FreeBSD, but it should still work..

Providing the version of things you are using (OS, Kibana) as well as any logs would be helpful :slight_smile:


#3

Ah, currently, I'm running FreeBSD 11.1, running Kibana 5.3.0. Copy of the last few lines of /var/log/kibana.log :

{"type":"log","@timestamp":"2017-08-26T18:37:06Z","tags":["info","optimize"],"pid":17473,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T18:37:16Z","tags":["info","optimize"],"pid":28593,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T18:38:25Z","tags":["info","optimize"],"pid":56413,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T18:38:41Z","tags":["info","optimize"],"pid":68214,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T18:42:45Z","tags":["info","optimize"],"pid":16907,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T18:43:01Z","tags":["info","optimize"],"pid":33850,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T20:52:57Z","tags":["info","optimize"],"pid":30448,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T21:02:07Z","tags":["info","optimize"],"pid":68507,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-26T21:27:19Z","tags":["info","optimize"],"pid":37410,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T16:59:29Z","tags":["info","optimize"],"pid":78511,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T19:53:27Z","tags":["info","optimize"],"pid":51287,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:07:12Z","tags":["info","optimize"],"pid":21963,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:07:39Z","tags":["info","optimize"],"pid":37926,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:07:56Z","tags":["info","optimize"],"pid":51410,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:08:24Z","tags":["info","optimize"],"pid":69149,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:08:42Z","tags":["info","optimize"],"pid":87011,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-27T20:09:27Z","tags":["info","optimize"],"pid":3585,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}
{"type":"log","@timestamp":"2017-08-30T13:14:39Z","tags":["info","optimize"],"pid":15257,"message":"Optimizing and caching bundles for kibana, timelion and status_page. This may take a few minutes"}

Any other information needed, please feel free to ask.


(Mark Walkom) #4

It looks like it's being restarted pretty regularly, is there something in the OS logs that might line up with these?


#5

This was probably my attempts at trying to restart it.

However, I don't appear to have any other logs that I can see that has any activity about Kibana at all, but if someone can point me in the right direction to look I can dump the logs here.

Thanks all! :smiley:


(Mark Walkom) #6

So how do you know it crashes? What do you mean by crash as well?


#7

The main reason I know it does, because not only do I not get a response from the server even if I disable it's firewall. (don't worry, this is super alpha non-prod) I also can see when I use htop that it tries to start the service as www user, but then it disappears.


#8

From the looks of things in /var/log/messages, I'm getting this when I try "sudo service kibana restart':

Sep 1 16:43:35 freebsd kernel: pid 26735 (node), uid 80: exited on signal 6
Sep 1 16:48:32 freebsd kernel: pid 86116 (node), uid 80: exited on signal 6

Which according to this: https://lists.freebsd.org/pipermail/freebsd-questions/2004-April/042665.html

Means this:

Signal 6 is SIGABRT -- see /usr/include/sys/signal.h. A process dying
with this signal is usually due to it calling the abort(3) function.
That generally indicates that the process itself has found that some
essential pre-requisite for correct function is not available and
voluntarily killing itself, rather than the process being killed by
the kernel because it ran over resource limits or looked at memory
addresses funny or something.

So, besides kibana.yml having the elasticsearch.url being set to "http://localhost:9200", what else is required after install?


#9

If there are any other logs that might be found to help with this I would be glad to present them.

Thank you all! :smiley:


#10

Maybe if I took this from a different route.

If anybody has a kibana.yml configuration that works on FreeBSD that they are willing to share here, I can take a look at it and try one change at a time to see if it works out for me.

Thanks all! :smiley:


(Mark Walkom) #11

If it runs it shouldn't really matter what OS is it.
But what does your config look like now, minus comments?


#12

The only thing minus comments should be:

elasticsearch.url: "http://localhost:9200"

There's also no firewall or anything enabled as this is a testbed.


(Mark Walkom) #13

Is it though?


#14

Yes, it is, which is what's confusing me. I'm trying to setup a basic installation, but it doesn't appear to be working.

I made a backup of the original file and removed all other text besides the aforementioned setting that was added.


#15

Welp, I hate beating a dead horse, but I guess no one else has had experience with the problem of my kind. So, I will close this in a week if no one else responds.

Thanks anybody who helped get me along.


(system) #16

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.