Kibana docker log issue

my kibana docker container show more response log:
{"type":"response","@timestamp":"2018-09-07T02:34:06Z","tags":[],"pid":11,"method":"get","statusCode":304,"req":{"url":"/ui/favicons/favicon-32x32.png","method":"get","headers":{"host":"******:8601","connection":"keep-alive","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.81 Safari/537.36","accept":"image/webp,image/apng,image/*,*/*;q=0.8","referer":"http://******:8601/app/kibana","accept-encoding":"gzip, deflate","accept-language":"zh-CN,zh;q=0.9,en;q=0.8,zh-TW;q=0.7","if-none-match":"\"8e183c2e644fb050707d89402e1f7a120a95e4d2\"","if-modified-since":"Fri, 17 Aug 2018 23:26:52 GMT"},"remoteAddress":"******","userAgent":"******","referer":"http://******:8601/app/kibana"},"res":{"statusCode":304,"responseTime":25,"contentLength":9},"message":"GET /ui/favicons/favicon-32x32.png 304 25ms - 9.0B"}

i don't want show response log,how to setting?Thanks

You can control this from the config/kibana.yml file, by adding a line for I think you can also use flags on the CLI, but the config file is easier. By default the value here is "*", which will log all response output. You can also use an array value, with whatever tags you want to filter on (like "error" for example). If you don't want any response logs, just give it an empty array: []

Chances are, you'll want to know about errors though, so this is probably a better choice: ["error"]

Either should stop response data from showing up in the logs.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.