Kibana exe file


(Sharon Sasporta) #1

I installed and run kibana : kibana-4.6.1-1.x86_64

To run the kibana I am using the command: sudo systemctl start kibana.service

But I am getting the error: Dec 5 17:43:41 eaasrt systemd: Failed at step EXEC spawning /usr/share/kibana/bin/kibana: No such file or directory

I found that the exe now exist in: /opt/kibana/bin/kibana

How do I control/manage it ?
How to fix it?

Regards,
Sharon.


(Lee Drengenberg) #2

Hi Sharon,

The install path did change recently from /opt/kibana to /usr/share/kibana. I'm trying to figure out exactly which release it changed in. It looks like it only changed to /usr/share/kibana in 5.0+. Did you try installing a 5.0 build of Kibana at some point?

  1. What OS are you on? Looks like Ubuntu?
  2. Did you download the .deb package and install that directly or did you update your apt repo and use apt-get install kibana?
  3. Was this an upgrade or clean install?
  4. If you're just getting started, but need Elasticsearch 2.x and Kibana 4.x you might want to consider the latest Kibana 4.x build https://www.elastic.co/downloads/past-releases/kibana-4-6-3
  5. If you're just getting started, you might want to consider 5.x versions?

Thanks,
Lee


(Sharon Sasporta) #3

Yes, in certain time I installed V5, but uninstall it later.

I am working on Linux: Red Hat Enterprise Linux Server release 7.0 (Maipo)

I install via rpm file. Clean installation.

I must stay with that version in this point of time.

Thanks
Sharon.


(Sharon Sasporta) #4

Issue solved.

I uninstalled the version, manually deleted the unnecessary kibana directories and install again.

I then received the following Warning: Unit file of kibana.service changed on disk, 'systemctl daemon-reload' recommended.

I run it, run the kibana and it worked.

Thanks,
Sharon.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.