Kibana Histogram unexpected line curve with cumulative value


(Isaac Hazan) #1

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{
"settings" : {
"number_of_shards" : 5
},
"mappings" : {
"fi" : {
"properties" : {
"evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },
"cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }
}
}
}
}'

The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

[image: enter image description here]

The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:

[image: enter image description here]

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/26eb4c3b-a821-4fdf-ac42-90db0cdcb8e5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #2

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{
"settings" : {
"number_of_shards" : 5
},
"mappings" : {
"fi" : {
"properties" : {
"evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },
"cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }
}
}
}
}'

The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

[image: enter image description here]

The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:

[image: enter image description here]

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Isaac Hazan) #3

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasticsearch@googlegroups.com [mailto:elasticsearch@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasticsearch@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at: https://github.com/elasticsearch/kibana/issues/740 https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{
"settings" : {
"number_of_shards" : 5
},
"mappings" : {
"fi" : {
"properties" : {
"evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },
"cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }
}
}
}
}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/003501cf440d%242c2ec540%24848c4fc0%24%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #4

I don't find the option a zero-fill checkbox in my kibana version.

I've got logstash v1.3.3

I'll try to get the last version of kibana.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no
data it assumes zero values instead of joining the points between the 2
interval.

I solved it by using a different kibana version, I effectively found 2
patches one with a zero-fill checkbox and another one with an option box. I
found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com <javascript:> [mailto:
elasti...@googlegroups.com <javascript:>] *On Behalf Of *Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com <javascript:>
Subject: Re: Kibana Histogram unexpected line curve with cumulative
value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{

"settings" : {

    "number_of_shards" : 5

},

"mappings" : {

    "fi" : {

        "properties" : {

            "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },

            "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }

        }

    }

}

}'

The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1fc19ee2-e1aa-433c-9239-96415c93ceff%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #5

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to
disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no
data it assumes zero values instead of joining the points between the 2
interval.

I solved it by using a different kibana version, I effectively found 2
patches one with a zero-fill checkbox and another one with an option box. I
found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com <javascript:> [mailto:
elasti...@googlegroups.com <javascript:>] *On Behalf Of *Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com <javascript:>
Subject: Re: Kibana Histogram unexpected line curve with cumulative
value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{

"settings" : {

    "number_of_shards" : 5

},

"mappings" : {

    "fi" : {

        "properties" : {

            "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },

            "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }

        }

    }

}

}'

The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e0bded3c-2a37-4d6f-af45-178dc9ecc053%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #6

here my inspect from kibana :

curl -XGET
'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty'
-d '{
"facets": {
"0": {
"date_histogram": {
"key_field": "@timestamp",
"value_field": "gclog.gc.mem.after",
"interval": "1h"
},
"global": true,
"facet_filter": {
"fquery": {
"query": {
"filtered": {
"query": {
"query_string": {
"query": "gc.type:GC OR gc.type:Full"
}
},
"filter": {
"bool": {
"must": [
{
"range": {
"@timestamp": {
"from": 1395227019780,
"to": "now"
}
}
}
]
}
}
}
}
}
}
}
},
"size": 0
}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to
disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no
data it assumes zero values instead of joining the points between the 2
interval.

I solved it by using a different kibana version, I effectively found 2
patches one with a zero-fill checkbox and another one with an option box. I
found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] *On
Behalf Of *Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative
value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{

"settings" : {

    "number_of_shards" : 5

},

"mappings" : {

    "fi" : {

        "properties" : {

            "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },

            "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }

        }

    }

}

}'

The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Isaac Hazan) #7

The attached will work for you.

From: elasticsearch@googlegroups.com [mailto:elasticsearch@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 1:06 PM
To: elasticsearch@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {

  "date_histogram": {

    "key_field": "@timestamp",

    "value_field": "gclog.gc.mem.after",

    "interval": "1h"

  },

  "global": true,

  "facet_filter": {

    "fquery": {

      "query": {

        "filtered": {

          "query": {

            "query_string": {

              "query": "gc.type:GC OR gc.type:Full"

            }

          },

          "filter": {

            "bool": {

              "must": [

                {

                  "range": {

                    "@timestamp": {

                      "from": 1395227019780,

                      "to": "now"

                    }

                  }

                }

              ]

            }

          }

        }

      }

    }

  }

}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at: https://github.com/elasticsearch/kibana/issues/740 https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{
"settings" : {
"number_of_shards" : 5
},
"mappings" : {
"fi" : {
"properties" : {
"evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },
"cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }
}
}
}
}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/005501cf4436%2402ebbc00%2408c33400%24%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Isaac Hazan) #8

The attached as well.

It’s another way to circumvent the problem

From: elasticsearch@googlegroups.com [mailto:elasticsearch@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 1:06 PM
To: elasticsearch@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {

  "date_histogram": {

    "key_field": "@timestamp",

    "value_field": "gclog.gc.mem.after",

    "interval": "1h"

  },

  "global": true,

  "facet_filter": {

    "fquery": {

      "query": {

        "filtered": {

          "query": {

            "query_string": {

              "query": "gc.type:GC OR gc.type:Full"

            }

          },

          "filter": {

            "bool": {

              "must": [

                {

                  "range": {

                    "@timestamp": {

                      "from": 1395227019780,

                      "to": "now"

                    }

                  }

                }

              ]

            }

          }

        }

      }

    }

  }

}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at: https://github.com/elasticsearch/kibana/issues/740 https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:

curl -XPOST localhost:9200/first_install -d '{
"settings" : {
"number_of_shards" : 5
},
"mappings" : {
"fi" : {
"properties" : {
"evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" },
"cumulativeValue" : { "type" : "integer", "index": "not_analyzed" }
}
}
}
}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com?utm_medium=email&utm_source=footer .
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/005b01cf4436%24208da430%2461a8ec90%24%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #9

On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.
It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 1:06 PM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {

  "date_histogram": {

    "key_field": "@timestamp",

    "value_field": "gclog.gc.mem.after",

    "interval": "1h"

  },

  "global": true,

  "facet_filter": {

    "fquery": {

      "query": {

        "filtered": {

          "query": {

            "query_string": {

              "query": "gc.type:GC OR gc.type:Full"

            }

          },

          "filter": {

            "bool": {

              "must": [

                {

                  "range": {

                    "@timestamp": {

                      "from": 1395227019780,

                      "to": "now"

                    }

                  }

                }

              ]

            }

          }

        }

      }

    }

  }

}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.
I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:
https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at:https://github.com/elasticsearch/kibana/issues/740
To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.
The mapping looks as follows:curl -XPOST localhost:9200/first_install -d '{ "settings" : { "number_of_shards" : 5 }, "mappings" : { "fi" : { "properties" : { "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" }, "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" } } } }}'
The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.
Following is the Kibana sreenshot:
The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:
Could it be related to the data formatting I did?
Thx in advance.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c232f7ad-021d-4b9d-b91b-7d4056deaae0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #10

I have the same issue with your version and I don't see where in kibana i
can say : disable zero-fill checkbox.

On Thursday, March 20, 2014 2:29:24 PM UTC+1, Xwilly Azel wrote:

On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.
It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On
Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 1:06 PM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative
value

here my inspect from kibana :

curl -XGET '
http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty'
-d '{

"facets": {

"0": { 

  "date_histogram": { 

    "key_field": "@timestamp", 

    "value_field": "gclog.gc.mem.after", 

    "interval": "1h" 

  }, 

  "global": true, 

  "facet_filter": { 

    "fquery": { 

      "query": { 

        "filtered": { 

          "query": { 

            "query_string": { 

              "query": "gc.type:GC OR gc.type:Full" 

            } 

          }, 

          "filter": { 

            "bool": { 

              "must": [ 

                { 

                  "range": { 

                    "@timestamp": { 

                      "from": 1395227019780, 

                      "to": "now" 

                    } 

                  } 

                } 

              ] 

            } 

          } 

        } 

      } 

    } 

  } 

} 

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option
to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with
no data it assumes zero values instead of joining the points between the 2
interval.
I solved it by using a different kibana version, I effectively found 2
patches one with a zero-fill checkbox and another one with an option box. I
found just one of them:
https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On
Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 9:12 AM
To: elasti...@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative
value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as
describe at:https://github.com/elasticsearch/kibana/issues/740
To overcome that I created a separate index where I calculate myself the
total and saved it to Elasticsearch.
The mapping looks as follows:curl -XPOST localhost:9200/first_install -d
'{ "settings" : { "number_of_shards" : 5 }, "mappings" :
{ "fi" : { "properties" : { "evtTime" : {
"type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss"
}, "cumulativeValue" : { "type" : "integer", "index":
"not_analyzed" } } } }}'
The values are saved properly but unexpectedly Kibana does not draw the
line i would expect, instead it joins between point that do not exist.
Following is the Kibana sreenshot:
The line curve should always be increasing since my data set is always
increasing, that i can prove by the following events as seen by kibana
itself:
Could it be related to the data formatting I did?
Thx in advance.

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8f4ea891-235f-45ad-acc9-5bbb6c14bb02%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #11

On Thursday, March 20, 2014 2:30:55 PM UTC+1, Xwilly Azel wrote:

I have the same issue with your version and I don't see where in kibana i can say : disable zero-fill checkbox.

On Thursday, March 20, 2014 2:29:24 PM UTC+1, Xwilly Azel wrote:On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.

It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 1:06 PM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {
  "date_histogram": {
    "key_field": "@timestamp",
    "value_field": "gclog.gc.mem.after",
    "interval": "1h"
  },
  "global": true,
  "facet_filter": {
    "fquery": {
      "query": {
        "filtered": {
          "query": {
            "query_string": {
              "query": "gc.type:GC OR gc.type:Full"
            }
          },
          "filter": {
            "bool": {
              "must": [
                {
                  "range": {
                    "@timestamp": {
                      "from": 1395227019780,
                      "to": "now"
                    }
                  }
                }
              ]
            }
          }
        }
      }
    }
  }
}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 9:12 AM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:curl -XPOST localhost:9200/first_install -d '{ "settings" : { "number_of_shards" : 5 }, "mappings" : { "fi" : { "properties" : { "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" }, "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" } } } }}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1e5aa19c-0132-4432-80c6-6542dd789bcb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #12

On Thursday, March 20, 2014 2:29:24 PM UTC+1, Xwilly Azel wrote:

On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.

It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 1:06 PM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {
  "date_histogram": {
    "key_field": "@timestamp",
    "value_field": "gclog.gc.mem.after",
    "interval": "1h"
  },
  "global": true,
  "facet_filter": {
    "fquery": {
      "query": {
        "filtered": {
          "query": {
            "query_string": {
              "query": "gc.type:GC OR gc.type:Full"
            }
          },
          "filter": {
            "bool": {
              "must": [
                {
                  "range": {
                    "@timestamp": {
                      "from": 1395227019780,
                      "to": "now"
                    }
                  }
                }
              ]
            }
          }
        }
      }
    }
  }
}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 9:12 AM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:curl -XPOST localhost:9200/first_install -d '{ "settings" : { "number_of_shards" : 5 }, "mappings" : { "fi" : { "properties" : { "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" }, "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" } } } }}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2c1cffb9-5987-474a-b488-8a159cf7a74b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Xwilly Azel) #13

On Thursday, March 20, 2014 3:18:35 PM UTC+1, Xwilly Azel wrote:

On Thursday, March 20, 2014 2:29:24 PM UTC+1, Xwilly Azel wrote:

On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.

It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 1:06 PM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {
  "date_histogram": {
    "key_field": "@timestamp",
    "value_field": "gclog.gc.mem.after",
    "interval": "1h"
  },
  "global": true,
  "facet_filter": {
    "fquery": {
      "query": {
        "filtered": {
          "query": {
            "query_string": {
              "query": "gc.type:GC OR gc.type:Full"
            }
          },
          "filter": {
            "bool": {
              "must": [
                {
                  "range": {
                    "@timestamp": {
                      "from": 1395227019780,
                      "to": "now"
                    }
                  }
                }
              ]
            }
          }
        }
      }
    }
  }
}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 9:12 AM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:curl -XPOST localhost:9200/first_install -d '{ "settings" : { "number_of_shards" : 5 }, "mappings" : { "fi" : { "properties" : { "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" }, "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" } } } }}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3592ba2f-1307-49fc-b64b-ff6f56e5553f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Isaac Hazan) #14

In the attached screenshot you sent, you are looking for it in the wrong place, it's not under "style", it's under "panel".
I attached what I am seeing.

-----Original Message-----
From: elasticsearch@googlegroups.com [mailto:elasticsearch@googlegroups.com] On Behalf Of Xwilly Azel
Sent: Thursday, March 20, 2014 3:42 PM
To: elasticsearch@googlegroups.com
Subject: Re: Kibana Histogram unexpected line curve with cumulative value

On Thursday, March 20, 2014 2:30:55 PM UTC+1, Xwilly Azel wrote:

I have the same issue with your version and I don't see where in kibana i can say : disable zero-fill checkbox.

On Thursday, March 20, 2014 2:29:24 PM UTC+1, Xwilly Azel wrote:On Thursday, March 20, 2014 1:15:44 PM UTC+1, Isaac Hazan wrote:

The attached as well.

It’s another way to circumvent the problem

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 1:06 PM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

here my inspect from kibana :

curl -XGET 'http://xxxxx:9200/logstash-2014.03.20,logstash-2014.03.19/_search?pretty' -d '{

"facets": {

"0": {
  "date_histogram": {
    "key_field": "@timestamp",
    "value_field": "gclog.gc.mem.after",
    "interval": "1h"
  },
  "global": true,
  "facet_filter": {
    "fquery": {
      "query": {
        "filtered": {
          "query": {
            "query_string": {
              "query": "gc.type:GC OR gc.type:Full"
            }
          },
          "filter": {
            "bool": {
              "must": [
                {
                  "range": {
                    "@timestamp": {
                      "from": 1395227019780,
                      "to": "now"
                    }
                  }
                }
              ]
            }
          }
        }
      }
    }
  }
}

},

"size": 0

}'

On Thursday, March 20, 2014 12:00:29 PM UTC+1, Xwilly Azel wrote:

I've upgrader to kibana 3.0.0.

Still the same issue, when I 'm doing an histogram, I don't have option to disable zero-fill checkbox.

On Thursday, March 20, 2014 8:22:35 AM UTC+1, Isaac Hazan wrote:

Yes, the problem is because when the histogram encounters buckets with no data it assumes zero values instead of joining the points between the 2 interval.

I solved it by using a different kibana version, I effectively found 2 patches one with a zero-fill checkbox and another one with an option box. I found just one of them:

https://github.com/elasticsearch/kibana/issues/741

Both versions solve the problem.

That’s the way I solved it.

Hope that helps

/Itzhak

From: elasti...@googlegroups.com [mailto:elasti...@googlegroups.com] On Behalf Of Xwilly Azel

Sent: Thursday, March 20, 2014 9:12 AM

To: elasti...@googlegroups.com

Subject: Re: Kibana Histogram unexpected line curve with cumulative value

I've got the same kind of issue.

Did you find a solution ?

On Monday, March 10, 2014 3:58:21 PM UTC+1, Isaac Hazan wrote:

Kibana cannot do a the Histogram of the cumulative value of a field as describe at:https://github.com/elasticsearch/kibana/issues/740

To overcome that I created a separate index where I calculate myself the total and saved it to Elasticsearch.

The mapping looks as follows:curl -XPOST localhost:9200/first_install -d '{ "settings" : { "number_of_shards" : 5 }, "mappings" : { "fi" : { "properties" : { "evtTime" : { "type" : "date", "index": "not_analyzed", "format": "dd/MMM/yyyy:HH:mm:ss" }, "cumulativeValue" : { "type" : "integer", "index": "not_analyzed" } } } }}'

The values are saved properly but unexpectedly Kibana does not draw the line i would expect, instead it joins between point that do not exist.

Following is the Kibana sreenshot:

The line curve should always be increasing since my data set is always increasing, that i can prove by the following events as seen by kibana itself:

Could it be related to the data formatting I did?

Thx in advance.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9fe1f350-c5fb-47f2-8925-2d52b7376d94%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.

To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/71e13a70-e6a6-4896-a050-62f2462ab085%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/mp2hUkR8U6w/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1e5aa19c-0132-4432-80c6-6542dd789bcb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/011201cf4841%24d1569420%247403bc60%24%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #15