Kibana in docker, issues with installation of plugins

Hey All - and thanks for any help in advance.

Im trying to install this plugin into kibana in docker:

my version is 7.7.1 which should work based on the docs. After copying from "kibana-plugins" I have tried using the command argument in my yaml file:

  - ./config/kibana.yml:/usr/share/kibana/config/kibana.yml:ro
  - ./config/kibana-plugins:/usr/share/kibana/plugins:ro

command: sh -c './bin/kibana-plugin install file:///usr/share/kibana/plugins/

i've also tried with a direct link to github but it always says "ENOENT: no such file or directory, mkdir"

I've also tried creating a dockerfile but im not sure im doing this right? how would i invoke this to install into an existing image?


    USER root
    RUN yum install git -y

    USER kibana
    RUN curl -o- | bash && . ~/.nvm/ && nvm install node && cd /usr/share/kibana/plugins && git clone network_vis -b 7-dev && cd network_vis && rm -rf images/ && npm install

Any ideas?

Thanks in advance!

Hi @twright8

I could run that plugin on 7.5.2 but not on 7.7.1 or 7.8.0.

I only had to mount the unzipped folder inside the /usr/share/kibana/plugins/network_vis. Check out the full configuration on this gist .

    container_name: kibana
      - 5601:5601
      - ./kibana.yml:/usr/share/kibana/config/kibana.yml
      - ./network_vis:/usr/share/kibana/plugins/network_vis
      - esnet
      - elasticsearch

You may want to open a ticket in this plugin repo to check with the author what could be missing to prevent it running on recent versions of Kibana.

thankyou thats amazing!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.