Kibana is not starting after upgrade from 6.7.1 to 7.2

I was previously using ELK 6.7.1 with searchguard. I've uninstalled the searchguard plugins and upgraded the ELK RPMs to 7.2. Elasticsearch seems to be up and running but Kibana will not start. I keep getting this error and can't find any relief from the internet.

{"type":"log","@timestamp":"2019-07-12T19:20:06Z","tags":["fatal","root"],"pid":28020,"message":"{ ValidationError: child \"kibana\" fails because [\"kibana\" must be an object]\n at Object.exports.process (/usr/share/kibana/node_modules/joi/lib/errors.js:196:19)\n at internals.Object._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:675:31)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n at Config._commit (/usr/share/kibana/src/legacy/server/config/config.js:132:34)\n at Config.set (/usr/share/kibana/src/legacy/server/config/config.js:102:10)\n at Config.extendSchema (/usr/share/kibana/src/legacy/server/config/config.js:74:10)\n at extendConfigService (/usr/share/kibana/src/legacy/plugin_discovery/plugin_config/extend_config_service.js:45:10) name: 'ValidationError' }"}

It wouldn't let me include the config in the original post so here it is.

Here's my config file:
> # Kibana is served by a back end server. This setting specifies the port to use.
> server.port: 5601
>
> # Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
> # The default is 'localhost', which usually means remote machines will not be able to connect.
> # To allow connections from remote users, set this parameter to a non-loopback address.
> server.host: "10.22.160.23"
>
> #Logging
> logging.dest: /var/log/kibana/kibana.log
>
> # Enables you to specify a path to mount Kibana at if you are running behind a proxy.
> # Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath
> # from requests it receives, and to prevent a deprecation warning at startup.
> # This setting cannot end in a slash.
> #server.basePath: ""
>
> # Specifies whether Kibana should rewrite requests that are prefixed with
> # server.basePath or require that they are rewritten by your reverse proxy.
> # This setting was effectively always false before Kibana 6.3 and will
> # default to true starting in Kibana 7.0.
> #server.rewriteBasePath: false
>
> # The maximum payload size in bytes for incoming server requests.
> #server.maxPayloadBytes: 1048576
>
> # The Kibana server's name. This is used for display purposes.
> #server.name: "your-hostname"
>
> # The URLs of the Elasticsearch instances to use for all your queries.
> elasticsearch.hosts: ["https://localhost:9200"]
>
> # When this setting's value is true Kibana uses the hostname specified in the server.host
> # setting. When the value of this setting is false, Kibana uses the hostname of the host
> # that connects to this Kibana instance.
> #elasticsearch.preserveHost: true
>
> # Kibana uses an index in Elasticsearch to store saved searches, visualizations and
> # dashboards. Kibana creates a new index if the index doesn't already exist.
> kibana.index: ".kibana"
>
> # The default application to load.
> kibana.defaultAppId: "home"
>
> # If your Elasticsearch is protected with basic authentication, these settings provide
> # the username and password that the Kibana server uses to perform maintenance on the Kibana
> # index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
> # is proxied through the Kibana server.
> elasticsearch.username: "kibana"
> elasticsearch.password: "${elasticsearch.password}"
>
> # Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
> # These settings enable SSL for outgoing requests from the Kibana server to the browser.
> server.ssl.enabled: false
> server.ssl.certificate: /etc/kibana/certs/cert.pem
> server.ssl.key: /etc/kibana/certs/key.pem
>
> # Optional settings that provide the paths to the PEM-format SSL certificate and key files.
> # These files validate that your Elasticsearch backend uses the same key files.
> #elasticsearch.ssl.certificate: /path/to/your/client.crt
> #elasticsearch.ssl.key: /path/to/your/client.key
>
> # Optional setting that enables you to specify a path to the PEM file for the certificate
> # authority for your Elasticsearch instance.
> elasticsearch.ssl.certificateAuthorities: [ "/etc/elasticsearch/certs/ca/ca.crt" ]
>
> # To disregard the validity of SSL certificates, change this setting's value to 'none'.
> elasticsearch.ssl.verificationMode: none
>
> # Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
> # the elasticsearch.requestTimeout setting.
> #elasticsearch.pingTimeout: 1500
>
> # Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
> # must be a positive integer.
> elasticsearch.requestTimeout: 100000
>
> # List of Kibana client-side headers to send to Elasticsearch. To send no client-side
> # headers, set this value to (an empty list).
> #elasticsearch.requestHeadersWhitelist: [ authorization ]
>
> # Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
> # by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
> #elasticsearch.customHeaders: {}
>
> # Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
> #elasticsearch.shardTimeout: 30000
>
> # Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.
> #elasticsearch.startupTimeout: 5000
>
> # Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
> #elasticsearch.logQueries: false
>
> # Specifies the path where Kibana creates the process ID file.
> #pid.file: /var/run/kibana.pid
>
> # Enables you specify a file where Kibana stores log output.
> #logging.dest: stdout
>
> # Set the value of this setting to true to suppress all logging output.
> #logging.silent: false
>
> # Set the value of this setting to true to suppress all logging output other than error messages.
> #logging.quiet: false
>
> # Set the value of this setting to true to log all events, including system usage information
> # and all requests.
> #logging.verbose: false
>
> # Set the interval in milliseconds to sample system and process performance
> # metrics. Minimum is 100ms. Defaults to 5000.
> #ops.interval: 5000
>
> # Specifies locale to be used for all localizable strings, dates and number formats.
> #i18n.locale: "en"
> xpack.security.enabled: true
> xpack.spaces.enabled: true
> xpack.monitoring.enabled: true
> xpack.monitoring.kibana.collection.enabled: true

Did you run the upgrade manager in kibana before upgrading?