Kibana keep restarting it self constantly


(Mikko Heinoja) #1

Hey,

I have this weird problems which appears suddently, my kibana keep restarting constantly and port 5601 never comes listening state (running elastic stack on windows"

Only thing which appears in kibana log is this:

{"type":"log","@timestamp":"2018-09-12T10:07:40Z","tags":["status","plugin:kibana@6.2.3","info"],"pid":57684,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

it keeps spamming only that

and in debug more it gives this

{"type":"log","@timestamp":"2018-09-12T11:38:02Z","tags":["plugins","debug"],"pid":5964,"plugin":{"name":"input_control_vis","version":"kibana"},"message":"Initializing plugin input_control_vis@kibana"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\console","message":"Found plugin at C:\ELK\kibana\src\core_plugins\console"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\elasticsearch","message":"Found plugin at C:\ELK\kibana\src\core_plugins\elasticsearch"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\input_control_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\input_control_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kbn_doc_views","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kbn_doc_views"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kbn_vislib_vis_types","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kbn_vislib_vis_types"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kibana","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kibana"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\markdown_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\markdown_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\metrics","message":"Found plugin at C:\ELK\kibana\src\core_plugins\metrics"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\metric_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\metric_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\region_map","message":"Found plugin at C:\ELK\kibana\src\core_plugins\region_map"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\spy_modes","message":"Found plugin at C:\ELK\kibana\src\core_plugins\spy_modes"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\state_session_storage_redirect","message":"Found plugin at C:\ELK\kibana\src\core_plugins\state_session_storage_redirect"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\status_page","message":"Found plugin at C:\ELK\kibana\src\core_plugins\status_page"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\table_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\table_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\tagcloud","message":"Found plugin at C:\ELK\kibana\src\core_plugins\tagcloud"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\tile_map","message":"Found plugin at C:\ELK\kibana\src\core_plugins\tile_map"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\timelion","message":"Found plugin at C:\ELK\kibana\src\core_plugins\timelion"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\vega","message":"Found plugin at C:\ELK\kibana\src\core_plugins\vega"}
{"type":"log","@timestamp":"2018-09-12T11:38:08Z","tags":["debug","optimize"],"pid":2388,"message":"All bundles are cached and ready to go!"}

I'm out of ideas


(Mikko Heinoja) #2

Hi,

I finaly found the solution and correct way for logging kibana

Error was:
"Error: Payload timeout must be shorter than socket timeout: POST /elasticsearch/{index}/_search\n

And this was the solution:

Mikko


(RJ Dowell) #3

domyhomework
Hey,

I have this weird problems which appears suddently, my kibana keep restarting constantly and port 5601 never comes listening state (running elastic stack on windows"

Only thing which appears in kibana log is this:

{"type":"log","@timestamp":"2018-09-12T10:07:40Z","tags":["status","plugin:kibana@6.2.3","info"],"pid":57684,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}

it keeps spamming only that

and in debug more it gives this

{"type":"log","@timestamp":"2018-09-12T11:38:02Z","tags":["plugins","debug"],"pid":5964,"plugin":{"name":"input_control_vis","version":"kibana"},"message":"Initializing plugin input_control_vis@kibana"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\console","message":"Found plugin at C:\ELK\kibana\src\core_plugins\console"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\elasticsearch","message":"Found plugin at C:\ELK\kibana\src\core_plugins\elasticsearch"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\input_control_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\input_control_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kbn_doc_views","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kbn_doc_views"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kbn_vislib_vis_types","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kbn_vislib_vis_types"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\kibana","message":"Found plugin at C:\ELK\kibana\src\core_plugins\kibana"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\markdown_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\markdown_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\metrics","message":"Found plugin at C:\ELK\kibana\src\core_plugins\metrics"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\metric_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\metric_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\region_map","message":"Found plugin at C:\ELK\kibana\src\core_plugins\region_map"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\spy_modes","message":"Found plugin at C:\ELK\kibana\src\core_plugins\spy_modes"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\state_session_storage_redirect","message":"Found plugin at C:\ELK\kibana\src\core_plugins\state_session_storage_redirect"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\status_page","message":"Found plugin at C:\ELK\kibana\src\core_plugins\status_page"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\table_vis","message":"Found plugin at C:\ELK\kibana\src\core_plugins\table_vis"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\tagcloud","message":"Found plugin at C:\ELK\kibana\src\core_plugins\tagcloud"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\tile_map","message":"Found plugin at C:\ELK\kibana\src\core_plugins\tile_map"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\timelion","message":"Found plugin at C:\ELK\kibana\src\core_plugins\timelion"}
{"type":"log","@timestamp":"2018-09-12T11:38:07Z","tags":["plugin","debug"],"pid":2388,"path":"C:\ELK\kibana\src\core_plugins\vega","message":"Found plugin at C:\ELK\kibana\src\core_plugins\vega"}
{"type":"log","@timestamp":"2018-09-12T11:38:08Z","tags":["debug","optimize"],"pid":2388,"message":"All bundles are cached and ready to go!"}

I'm out of ideas

Hello

I'm stuck with route.options.payload.timeout ( Default value: to 10000 (10 seconds).) and seems that nothing works for me. What should I do to change the time when I disable it?
Thanks,
RJ Dowell
Facebook - connect rj.dowell.9


(Mikko Heinoja) #4

Hi,

elasticsearch.requestTimeout default value is 30000ms and route.options.payload.timeout default value is 10000ms which you can't change as far as I know. That is why it keeps giving error "Payload timeout must be shorter than socket timeout". Don't know why those default values are wrong by default, maybe a bug. You need to set elasticsearch.requestTimeout no more than 10000ms and then kibana should start normaly

Mikko


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.