Kibana - Log - kibana-monitoring

Hello all, i just started up my cluster for the first time, it is composed of 2 data nodes and 1 master node, then i started up kibana, but i am having these warnings:

    log   [16:40:30.928] [warning][kibana-monitoring][monitoring][monitoring][plugins] Unable to bulk upload the stats payload to the local cluster
    log   [16:40:40.955] [warning][kibana-monitoring][monitoring][monitoring][plugins] Error: [export_exception] failed to flush export bulks
    at respond (/home/elkadmin/kibana-7.7.0-linux-x86_64/node_modules/elasticsearch/src/lib/transport.js:349:15)
    at checkRespForFailure (/home/elkadmin/kibana-7.7.0-linux-x86_64/node_modules/elasticsearch/src/lib/transport.js:306:7)
    at HttpConnector.<anonymous> (/home/elkadmin/kibana-7.7.0-linux-x86_64/node_modules/elasticsearch/src/lib/connectors/http.js:173:7)
    at IncomingMessage.wrapper (/home/elkadmin/kibana-7.7.0-linux-x86_64/node_modules/elasticsearch/node_modules/lodash/lodash.js:4929:19)
    at IncomingMessage.emit (events.js:203:15)
    at endReadableNT (_stream_readable.js:1145:12)

i don't know what these warnings mean and i don't know if should i pay attention or not.

The kibana.yml is: "" "kibana001"
    elasticsearch.hosts: ["","",""] 

Note: Kibana is running on a separate server


    # ---------------------------------- Cluster ----------------------------------- sysad-prod  
    # ------------------------------------ Node ------------------------------------ prod-master-1
    # ----------------------------------- Paths ------------------------------------ /var/lib/elasticsearch/data

    path.logs: /var/log/elasticsearch
    node.master: true 
    node.voting_only: false false 
    node.ingest: false 
    # ----------------------------------- Memory -----------------------------------
    bootstrap.memory_lock: true
    # ---------------------------------- Network -----------------------------------
    http.port: 9200
    # --------------------------------- Discovery ----------------------------------
    discovery.seed_hosts: ["", "", ""]
    cluster.initial_master_nodes: ["prod-master-1", "prod-data-1", "prod-data-2"]
    # ---------------------------------- Gateway -----------------------------------
    gateway.recover_after_nodes: 3 
    gateway.recover_after_time: 10m
    xpack.monitoring.collection.enabled: true

For the other 2 Elastic nodes is the same config, the only changes are the name of the node and that the other 2 nodes are data nodes as well

Just finally i have not started logstash yet

1 Like

I kindly suggest you to check the monitoring docs if you found some missing steps:
If you are not using the monitoring you can probably remove the xpack.monitoring.collection.enabled: true flag from the elasticsearch.yml files to clean that error

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.