Kibana: mapping set to strict, dynamic introduction of [references] within [doc] is not allowed

Just a heads up that we are looking into this one.

4 Likes

Thanks..:slight_smile:

Should have opened this report in github sooner, could have got ball rolling sooner..

Raul

Not to worry :slight_smile:

Bump.. this is affecting me as well. Any updates? =D

I got the same issue as well, waiting for the fix....:frowning:

I believe they closed this github issue already that I started (link is found few posts back).

I do not know exactly , why it happened, but as I tried it again, I managed to get this to work. If you're still having problems, you should open an issue etc..

Raul

I can easily reproduce the problem. I have, however, found a work-around:

  • Before upgrading, you should close down/stop the kibana service.
  • Make the upgrade
  • Wait until you are sure that the elasticsearch have been upgraded and is fully functional.
  • Then start the kibana service - now it magically upgrades its internal indexes to 7.0.

(my theory is that the kibana service makes a half upgrade if it cannot connect to the elasticsearch service and then fails).

Hope it also works for you.

1 Like

I share your opinion Thomas Qvist.

At first I did little bit lousy job during an upgrade. I upgraded both nodes (elastic and kibana) and I did not set this cluster.initial_master_nodes on either of the elasticsearch nodes, so they did not start up at first, so basically had some problems.

At last attempt, I shut down both nodes, set this parameter cluster.initial_master_nodes on first node and after startup it did initial bootstrapping on that node, then removed this parameter from elasticsearch.yml and restarted service normally on first node.
After that you are good to upgrade other nodes as usual (no more bootstrapping needed).

If someone could perhaps try this theory out. I myself would like mark this question as solved (Thomas Qvist answer).

Regards
Raul

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.