Kibana maximum results capped at 10000

We are using Elastic and Kibana version on 7.10.
As per the documentations, the maximum results returned would be 10000. However this causes a real issue for us in the metric visualization where we use visualization to show total document count. Changing the index. max_result_window to 100000 did not help to get to show more than 10K. How to get this worked around? How to pass track total hits property to elasticsearch on every request from Kibana.

Can you show the configuration of your visualization and point out what you would expect to happen? The metric visualization doesn't use the hits, but aggregations to figure out the document count which shouldn't be subject to the parameters you mention.

Hi.. Thanks for reviewing this issue.

I am doing a very simple step .. Created an index in Elasticsearch which has more than 10K documents( say 11200 )....

In Kibana i created an index pattern on this index and creating a metric visualization just by selecting a term field. This in 6.x or 7.0 etc gave me the exact count of 11200 but same data, same visualization it shows 10000 as the number.

Can you please provide these things:

  • A screenshot of your visualization configuration or the exported saved object
  • The request being send by the visualization (click the "Inspect" button and switch the view to "Requests")
  • How do you know there are 112000 documents?

Hi,

Thanks again.
I take the total count from ES with the index document count. Attached are the details you asked for...


Screenshot 2021-04-01 at 11.11.28 AM

We can see the visualization limits the size to 10000. This was not the case in earlier releases.
Changing this to higher number and import did not help. Advanced settings

Hmmm this is 7.12 I will try 7.10 tomorrow when I get a chance...

Metric

And Lens

Can you show us the request and response from the Inspect button that I highlighted? Did you set something on the Options setting like a Range?

I tried to reproduce this on 7.10.2 using sample data but it works just fine for me.

Did you change any settings on you index or cluster? Which version of Kibana and Elasticsearch are you using exactly?