Kibana not connecting

I am extremely new to elasticsearch and Kibana. I have been able to get my elasticsearch instance running, but my Kibana will not connect.

[root@elasticsearch01 log]# curl -GET http://x.x.182.5:9200
"name" : "elasticsearch01",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "Htag37XMQ4i4jo0pwKk4wg",
"version" : {
"number" : "7.0.1",
"build_flavor" : "default",
"build_type" : "rpm",
"build_hash" : "e4efcb5",
"build_date" : "2019-04-29T12:56:03.145736Z",
"build_snapshot" : false,
"lucene_version" : "8.0.0",
"minimum_wire_compatibility_version" : "6.7.0",
"minimum_index_compatibility_version" : "6.0.0-beta1"
"tagline" : "You Know, for Search"


[root@elasticsearch01 log]# curl -XGET http://x.x.182.5:5601/status -I
curl: (7) Failed connect to x.x.182.5:5601; Connection refused
[root@elasticsearch01 log]#

Are you sure you are running Kibana on the port 5601?
Can you post your Kibana logs please

That's the weird thing. I set my kibana logs to go to /var/log/kibana, but I am getting nothing there. Here is my kibana.yaml

Kibana is served by a back end server. This setting specifies the port to use.

server.port: 5601

Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

The default is 'localhost', which usually means remote machines will not be able to connect.

To allow connections from remote users, set this parameter to a non-loopback address. x.x.182.5

Enables you to specify a path to mount Kibana at if you are running behind a proxy.

Use the server.rewriteBasePath setting to tell Kibana if it should remove the basePath

from requests it receives, and to prevent a deprecation warning at startup.

This setting cannot end in a slash.

#server.basePath: ""

Specifies whether Kibana should rewrite requests that are prefixed with

server.basePath or require that they are rewritten by your reverse proxy.

This setting was effectively always false before Kibana 6.3 and will

default to true starting in Kibana 7.0.

#server.rewriteBasePath: false

The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

The Kibana server's name. This is used for display purposes. elasticsearch01

The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: http://x.x.182.5:9200

When this setting's value is true Kibana uses the hostname specified in the

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

#elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn't already exist.

#kibana.index: ".kibana"

The default application to load.

#kibana.defaultAppId: "home"

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

#elasticsearch.username: "user"
#elasticsearch.password: "pass"

Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

Optional settings that provide the paths to the PEM-format SSL certificate and key files.

These files validate that your Elasticsearch backend uses the same key files.

#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

Optional setting that enables you to specify a path to the PEM file for the certificate

"/etc/kibana/kibana.yml" 114L, 5077C

Which command are you launching Kibana with?
Have you created the repository where you want kibana to write logs and did you set permission on it?
Maybe you have errors on your Kibana launching

sytemctl start kibana
I have not created a repository. Not sure of the steps to do that.

Instead of running it with systemctl just try to run it with ./bin/kibana first. If it works you can run it with systemctl
For the repository a simple mkdir will do the work

./bin/kibana did not work.

./bin/kibana: No such file or directory

Did you run this command in the bin reposiroty of your kibana?

[root@elasticsearch01 kibana]# ./bin/kibana

FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

Seems like you already launched your kibana.
netstat -nlp | grep 5601 to see the instance running on that port and get the intance-pid
You should have something like: tcp 0 0 LISTEN 11261/./../node/bin*
kill instance-pid the instance-pid for the example up there is 11261
The run the command ./bin/kibana again

1 Like

Thank you soo much. This worked for me.

You're welcome mate.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.