Kibana Plugin for xlsx import


(Gautham) #1

Hi All,

Have found this git page which searching for xlsx import

This explains that we can import xlsx file directly from kibana if we install this plugin, have to trying to install it and getting errors

Error: Client request error: socket hang up
Plugin installation was unsuccessful due to error "Client request error: socket hang up"

Has anybody faced this type of issue before, else anyone succeeded in installing this plugin...Please help.

Thanks
Gautham


(Tim Roes) #2

socket hang up usually means, that there has been some errors around the network. Can you actually check if you are able to retrieve the file from that system the Kibana server is running on? E.g. try a curl -I https://github.com/kyushy/kibana-xlsx-import/releases/download/6.2.3/xlsx-import-6.2.3-react-latest.zip > /dev/null and show the output if that?


(Gautham) #3

@timroes here is the output.

curl -I https://github.com/kyushy/kibana-xlsx-import/releases/download/6.2.3/xlsx-import-6.2.3-react-latest.zip > /dev/null

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (35) Peer reports incompatible or unsupported protocol version.

Thanks
Gautham


(Tim Roes) #4

That really looks like you are seeing a different output than I am. Could you perhaps check a) your curl version curl -V and b) execute the command again in verbose mode:

curl -v https://github.com/kyushy/kibana-xlsx-import/releases/download/6.2.3/xlsx-import-6.2.3-react-latest.zip > /dev/null


(Gautham) #5

@timroes here is the output in verbose mode

[root@elk624 bin]# curl -V
curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.15.4 zlib/1.2.7 libidn/1.28 libssh2/1.4.3
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz
[root@elk624 bin]#
[root@elk624 bin]# curl -v https://github.com/kyushy/kibana-xlsx-import/releases/download/6.2.3/xlsx-import-6.2.3-react-latest.zip > /dev/null
* About to connect() to proxy 10.132.117.28 port 9090 (#0)
*   Trying 10.132.117.28...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Connected to 10.132.117.28 (10.132.117.28) port 9090 (#0)
* Establish HTTP proxy tunnel to github.com:443
> CONNECT github.com:443 HTTP/1.1
> Host: github.com:443
> User-Agent: curl/7.29.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.0 200 Connection established
<
* Proxy replied OK to CONNECT request
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* NSS error -12190 (SSL_ERROR_PROTOCOL_VERSION_ALERT)
* Peer reports incompatible or unsupported protocol version.
* Error in TLS handshake, trying SSLv3...
* TLS disabled due to previous handshake failure
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* NSS error -5938 (PR_END_OF_FILE_ERROR)
* Encountered end of file
* Closing connection 0
curl: (35) Peer reports incompatible or unsupported protocol version.

(Tim Roes) #6

You are actually connecting through a proxy. That proxy seems not to handle TLS properly, since you can see, that you've get some SSL_ERROR_PROTOCOL_VERSION_ALERT. So I am not sure if it will be possible to get this working behind that proxy. Please consult whoever is managing that proxy, that you are using, and just show them that above curl request. As soon as that curl is working, Kibana shouldn't have an issue anymore downloading that plugin.

Cheers,
Tim


(Gautham) #7

Yeah @timroes i'm using proxy to connect to internet, thanks for the information i'll check with the administrator regarding this.

One more thing i have even downlaoded the plugin manually, is there a way where i can install it manually?
The github page instruction have provided a manual link to download the plugin as well, but there was no steps provided for installation :frowning:

Thanks
Gauti


(Tim Roes) #8

Yeah you can just use a local file link instead. See this example in the documentation.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.