Kibana problem visualize scripted fields


im trying to convert an integer field like "1,676,274,668" to an Date/Datetime field and visualize it afterwards with Kibana.
I use a scripted field which can be seen on the next picture.

Here everything looks just fine

Now I just want to display the last value that was read, but this is not possible on a date field.

I also get this error, but only with the scripted field. Otherwise all fields can be displayed without problems. Search.max_buckets I would not like to increase because only this field causes problems and I don't know to which value I have to change it to make it work.

Hi @Anonym123

what type of visualization are you using to visualize the field?
I think only the legacy metric (Kibana > 8.5, or simply Metric before) can handle that - as it won't make sense for other chart types.
I've tried to visualize a runtime date field with the legacy metric visualization in Lens and it worked fine:

I currently use version 7.17.3 . Since I have more dates I would like to display more at once, such as with the Tabele. Unfortunately it does not work with this. I can't find the visualization legacy metric on my end only the normal metric probably because I'm using Kibana 7.17.3 . Did I do something wrong with the conversion from int to date? The dates actually look correct. I have tested several visualizations with this field, none of them works.

Support for dates for the last_value in Lens has been added since 8.2.0 release:

I just updated the full ELK up to 8.5.1 .
The scripted field exists in many documents, but when I try to display it, Kibana now says "No field data for the current search".
In the next picture you can see that the field exists and contains data.
But if i want to create a visualization Kibana says.
I also filterd the visualization with documents that only contains this field.

Still the bucket error

If you create a Legacy metric with it does it prompt any error or just empty data?

Ahh it only says that there is no data in it but when I drag the dataset in with legacy or table it still works. Thanks problem solved

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.