Kibana running on 0.0.0.0 but other computer not able to access it

Here is the kibana.yml. I can access kibana from my ip address, but when I gave my ip address to another user to access kibana, it wont let them access

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"

I have turned off my firewall as well. Please help!

Hi @Mehak_Bhargava,

Your configuration looks fine.

Can the other user access your ip in general? For example does ping <YOUR IP ADDRESS> work? If that's not the case it's indicating a problem with routing not related to Kibana.

Hi @flash1293,

Others are able to ping my ip. Just not able to access kibana port. What else could be an issue?

@flash1293

here is my kibana.yml-

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name.  This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
#elasticsearch.hosts: ["http://localhost:9200"]

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

Please help whats the issue.

Hey Mehak,

can you share the netstat results.

Use command : netstat -plant and netstat -tlunp

Or check if kibana port is in listening state : netstat -plant | grep 5601

Thanks
Anshu

Hey, could you run the command @AnshuPal posted and paste the results here?

It might also be worth it checking with your network administrator whether ports other than 80/443 get blocked.