Kibana saved search object embed autofocus issue

I'm trying to embed a saved search and resulting report in an external site, which is simple enough. The problem is that the query field is set to autofocus, so my webpage automatically scrolls down to the text field for the query, which is more than halfway down the page and wholly undesired. Does anyone know of a way to get around this or supersede this function?

Hi Cameron,

Can you check if there is an embed=true query string parameter in the URL you are using in the embed code?



Yes, I have the embed parameter included in the URL. And I've tried both the share saved search and share snapshot links with the embed parameter, to no avail.

Okay, something doesn't seem right then. With embed=true in the query string you should not be seeing the text field for the query at all. Would you mind pasting the complete URL you are using in your embed code here? And also a screenshot of what the embedded Kibana looks like? Also, what version of Kibana are you using?



I'm running 5.0.2 locally

Don't mean to be a bother, but do you have an idea as to what I'm doing wrong? Would any more information be helpful?


Hi @cameshgh,

I just tried to reproduce this with 5.0.2 and was able to see the query field as well. However, when I tried to reproduce it with the latest version of Kibana, I was not able to see the query field.

At this point I suspect this was a bug in 5.0.2 that was fixed in a later version. So I'd suggest upgrading your Elastic stack to the latest version to get rid of this issue.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.