Kibana server is not ready yet kibana.service: Main process exited, code=exited, status=1/FAILURE

Sorry if this post is repetitive, I did look for this issue and did not see an answer that worked for me. I realize this could turn out to be something fairly simple or even an OSI level 8 error.

I can't imaging that I am the first one to experience this issue trying to set up Kibana. For the record I did try at least one suggestion form a similar topic and it did not seem to work for me or resolve my issue.

I'm getting this error:

Opening this on the host machine: 192 . 168 . 1 . 125 : 5601/ results in this error message:
Kibana server is not ready yet

Kibana us running in Ubuntu 18.04 on a VM on Virtual Box on the host machine.

Could this be as simple as not having a kibana log destination file in kabana.yml? I thought I had tried that but somehow it seems to have reverted to before I added it in per another post I saw here. Also wondering it it could be because of file permissions that may need to also be adjusted that kibana can't run because it can't reach a core file and so it stops?

I can't really tell for sure which version of kibana is installed because lo c a l h o s t :9200 returns an empty response (is there another way to tell?)

Upon checking the status of Kibana as follows: systemctl status kibana shows this:

root@elk:/etc/kibana# systemctl status kibana
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2023-07-19 18:56:17 UTC; 4h 46min ago
 Main PID: 25825 (node)
    Tasks: 11 (limit: 4653)
   CGroup: /system.slice/kibana.service
           └─25825 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli/dist --logging.dest=/var/log/kibana/kibana.log --pid.file=/run/kibana/ --deprecation.skip_deprecated_settings[0]=logging.dest

Jul 19 18:56:17 elk systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Jul 19 18:56:17 elk systemd[1]: kibana.service: Failed with result 'exit-code'.
Jul 19 18:56:17 elk systemd[1]: Stopped Kibana.
Jul 19 18:56:17 elk systemd[1]: Started Kibana.

Here is the content of my kibana.yml file.

# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address. "192(.)168(.)1(.)125"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name.  This is used for display purposes. "home-lab"

# The URLs of the Elasticsearch instances to use for all your queries.
#elasticsearch.hosts: ["(http): (//) (localhost:9200)"]

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "kibana_system"
elasticsearch.password: "obfuscated"

# Kibana can also authenticate to Elasticsearch via "service account tokens".
# If may use this token instead of a username/password.
# elasticsearch.serviceAccountToken: "my_token"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /run/kibana/

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"
server.ssl.enabled: true
server.ssl.certificate: "/etc/kibana/certs/kibana.crt"
server.ssl.key: "/etc/kibana/certs/kibana.key"

elasticsearch.hosts: [""]
elasticsearch.ssl.certificateAuthorities: ["/etc/kibana/certs/ca/ca.crt"]
elasticsearch.ssl.certificate: "/etc/kibana/certs/kibana.crt"
elasticsearch.ssl.key: "/etc/kibana/certs/kibana.key"

server.publicBaseUrl: "" true "30m"
xpack.encryptedSavedObjects.encryptionKey: "SomeReallyReallyLongEncryptionKey"


Is there another file I need to check something in or post on this thread? Any assistance is appreciate. This is my first post so please go easy on my while I learn to overcome any noob mistakes I may make while learning to post appropriately in forums.


Kibana 6.3 is EOL and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

I found that the version number according to the installer is 7.17.11

Also, I found this on Stack Overflow and now Kibana appears to run with no errors but it hasn't loaded in my browser yet.

I experienced the same issue as mentioned above when tried ($sudo systemctl start kibana.service) to start Kibana. Issue: Failed to start Kibana using systemctl, but works fine through bin file. Resolution: /etc/systemd/system/kibana.service file was trying to start kibana using the User=kibana Group=kibana where either of them exists. This is resolved after creating the kibana user, kibana group and restarting kibana. `$useradd kibana
$groupadd kibana
$usermod -a -G kibana kibana` Hope this helps.

After I fixed another little issue I found, (nothing like a typo to frustrate you, right?) I'm happy to report that this is resolved and now working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.