Kibana Server not ready yet

Hi Everyone,
I have installed kibana and elastic search on my VM, elasticsearch is running and accessible outside the VM but when I run kibana and try to access on the browser it showing kibana server not ready yet.but kibana is running properly

When I put command for log below logs are generated :-1:

kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)
Active: active (running) since Fri 2020-04-24 15:35:25 UTC; 36s ago
Main PID: 2669 (node)
Tasks: 11 (limit: 4915)
CGroup: /system.slice/kibana.service
└─2669 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","config"],"pid":2669,"message":"Marking config pa
th as handled: usageCollection"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","config"],"pid":2669,"message":"Marking config pa
th as handled: xpack,cloud"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","legacy-service"],"pid":2669,"message":"setting u
p legacy service"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","root"],"pid":2669,"message":"starting root"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","server"],"pid":2669,"message":"starting server"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","savedobjects-service"],"pid":2669,"message":"Sta
rting SavedObjects service"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","config"],"pid":2669,"message":"Marking config pa
th as handled: migrations"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["info","savedobjects-service"],"pid":2669,"message":"Wait
ing until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations..."}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["debug","plugins","licensing"],"pid":2669,"message":"Impo
rted license information from Elasticsearch:type: undefined | status: undefined | expiry date: Invalid date"}
Apr 24 15:35:34 elkstack-vm kibana[2669]: {"type":"log","@timestamp":"2020-04-24T15:35:34Z","tags":["info","savedobjects-service"],"pid":2669,"message":"Star
ting saved objects migrations"}
Please Help me out !!

I have downloaded the latest version of kibana and elastic search

Hi @aman97,

Seems from the log it is a license issue:

"Imported license information from Elasticsearch:type: undefined | status: undefined | expiry date: Invalid date"

Please check and let us know.

Thanks,
Liza

Hi Liza,
Thanks for the reply, Didn't get you can you please elaborate more as I am new to ELK stack , Today i get below logs
Apr 27 08:35:26 elkstack-vm kibana[1624]: {"type":"log","@timestamp":"2020-04-27T08:35:26Z","tags":["warning","plugins","licensing"],"pid":1624,"message":"Li
cense information could not be obtained from Elasticsearch due to Error: Request Timeout after 30000ms error"}
Apr 27 08:35:56 elkstack-vm kibana[1624]: {"type":"log","@timestamp":"2020-04-27T08:35:56Z","tags":["warning","plugins","licensing"],"pid":1624,"message":"Li
cense information could not be obtained from Elasticsearch due to Error: Request Timeout after 30000ms error"}
Apr 27 08:35:59 elkstack-vm kibana[1624]: {"type":"log","@timestamp":"2020-04-27T08:35:59Z","tags":["debug","http"],"pid":1624,"message":"Kibana server is no
t ready yet get:/."}

Hi @aman97,

Yes sure let me get some more details from you, what version of the stack are you using? Can you provide me with non-private settings you have in elasticsearch.yml and kibana.yml ? Along with OS or installation/download site information, I can take a look.

Thanks,
Liza

Hi @LizaD
I am using the 7.6.2 version for both ES and Kibana and I downloaded from the official elastic.co and the environment I am using is Linux
Now I am getting below Kibana logs
log [15:05:41.236] [info][plugins-service] Plugin "case" is disabled.
log [15:05:45.883] [info][plugins-system] Setting up [37] plugins: [taskManager,siem,licensing,infra,encryptedSavedObjects,code,usageCollection,metrics,canvas,timelion,features,security,apm_oss,translations,reporting,uiActions,data,navigation,status_page,share,newsfeed,kibana_legacy,management,dev_tools,inspector,expressions,visualizations,embeddable,advancedUiActions,dashboard_embeddable_container,eui_utils,home,spaces,cloud,apm,graph,bfetch]
log [15:05:45.884] [info][plugins][taskManager] Setting up plugin
log [15:05:45.900] [info][plugins][siem] Setting up plugin
log [15:05:45.901] [info][licensing][plugins] Setting up plugin
log [15:05:45.904] [info][infra][plugins] Setting up plugin
log [15:05:45.905] [info][encryptedSavedObjects][plugins] Setting up plugin
log [15:05:45.906] [warning][config][encryptedSavedObjects][plugins] Generating a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to decrypt encrypted saved objects attributes after restart, please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml
log [15:05:45.911] [info][code][plugins] Setting up plugin
log [15:05:45.912] [info][plugins][usageCollection] Setting up plugin
log [15:05:45.913] [info][metrics][plugins] Setting up plugin
log [15:05:45.914] [info][canvas][plugins] Setting up plugin
log [15:05:45.919] [info][plugins][timelion] Setting up plugin
log [15:05:45.920] [info][features][plugins] Setting up plugin
log [15:05:45.921] [info][plugins][security] Setting up plugin
log [15:05:45.922] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml
log [15:05:45.923] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
log [15:05:45.941] [info][apm_oss][plugins] Setting up plugin
log [15:05:45.942] [info][plugins][translations] Setting up plugin
log [15:05:45.943] [info][data][plugins] Setting up plugin
log [15:05:45.949] [info][plugins][share] Setting up plugin
log [15:05:45.951] [info][home][plugins] Setting up plugin
log [15:05:45.956] [info][plugins][spaces] Setting up plugin
log [15:05:45.961] [info][cloud][plugins] Setting up plugin
log [15:05:45.962] [info][apm][plugins] Setting up plugin
log [15:05:45.966] [info][graph][plugins] Setting up plugin
log [15:05:45.969] [info][bfetch][plugins] Setting up plugin
log [15:05:45.975] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...
log [15:05:46.035] [info][savedobjects-service] Starting saved objects migrations
Could not create APM Agent configuration: Request Timeout after 30000ms
log [15:06:16.040] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: Request Timeout after 30000ms

and ES Config File
network.host: 0.0.0.0
discovery.seed_hosts:
cluster.initial_master_nodes:["node-1"]
rest are default

Kibana config file
server.port: 5601
server.port: 0.0.0.0
rest are default

Thanks @aman97,

I think the elasticsearch.yml settings needs to be updated to the below, I believe you are just missing the node.name setting in your config:

network.host: 0.0.0.0
node.name: node-1 
discovery.seed_hosts: ["127.0.0.1"]
cluster.initial_master_nodes: ["node-1"]

Please try and let me know.

Thanks,
Liza

Hi @LizaD

Thanks for your support, Finally the issue have been resolve.
great thanks!!

1 Like

Great to hear @aman97!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.