Kibana Service will not start


(Simroo) #1

Hello
I have some problem when trying to connect to my Kibana via localhost on the host.
I get the error Bad Gateway 502. And the services Kibana will not start at all.
The logs in /var/log/kibana/kibana.stderr show :

/opt/kibana/bin/../node/bin/node: 1: /opt/kibana/bin/../node/bin/node: cannot create @▒j@@@@: Permission denied
/opt/kibana/bin/../node/bin/node: 1: /opt/kibana/bin/../node/bin/node:ELF: not found

and im not sure why, i get that it does not have rights but i have dubbelcheck it, and even after running this command :sudo chmod +x /etc/init.d/kibana
sudo update-rc.d kibana defaults 96 9
sudo service kibana start
but still
ls -la kibana
-rwxrwxrwx 1 root root 3271 dec 16 17:13 kibana

What iam i missing or doing wrong ?


(Vincent Tran) #2

Is that how the message display in your stderr?
Run these and report back with the output:

file /opt/kibana/node/bin/node
java -version


(Jim Unger) #3

What version of Kibana did you download and what OS are you on?


(Simroo) #4

Hello

file /opt/kibana/node/bin/node
/opt/kibana/node/bin/node: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped
@netmanager:/etc/default$ java -version
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
Java HotSpot(TM) Client VM (build 25.66-b17, mixed mode)
@netmanager:/etc/default$


(Simroo) #5

/opt/kibana/node/bin/node
/opt/kibana/node/bin/node: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

Running debian Linux


(Simroo) #6

Please find the config files if needed

exit $?
@netmanager:/opt/kibana/config$ cat kibana.yml

Kibana is served by a back end server. This controls which port to use.

server.port: 5601

The host to bind the server to.

server.host: "localhost"

A value to use as a XSRF token. This token is sent back to the server on each request

and required if you want to execute requests from other clients (like curl).

server.xsrf.token: ""

If you are running kibana behind a proxy, and want to mount it at a path,

specify that path here. The basePath can't end in a slash.

server.basePath: ""

The Elasticsearch instance to use for all your queries.

elasticsearch.url: "http://localhost:9200"

preserve_elasticsearch_host true will send the hostname specified in elasticsearch. If you set it to false,

then the host you use to connect to this Kibana instance will be sent.

elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations

and dashboards. It will create a new index if it doesn't already exist.

kibana.index: ".kibana"

The default application to load.

kibana.defaultAppId: "discover"

If your Elasticsearch is protected with basic auth, these are the user credentials

used by the Kibana server to perform maintenance on the kibana_index at startup. Your Kibana

users will still need to authenticate with Elasticsearch (which is proxied through

the Kibana server)

elasticsearch.username: "user"

elasticsearch.password: "pass"

SSL for outgoing requests from the Kibana Server to the browser (PEM formatted)

server.ssl.cert: /path/to/your/server.crt

server.ssl.key: /path/to/your/server.key

Optional setting to validate that your Elasticsearch backend uses the same key files (PEM formatted)

elasticsearch.ssl.cert: /path/to/your/client.crt

elasticsearch.ssl.key: /path/to/your/client.key

If you need to provide a CA certificate for your Elasticsearch instance, put

the path of the pem file here.

elasticsearch.ssl.ca: /path/to/your/CA.pem

Set to false to have a complete disregard for the validity of the SSL

certificate.

elasticsearch.ssl.verify: true

Time in milliseconds to wait for elasticsearch to respond to pings, defaults to

request_timeout setting

elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or elasticsearch.

This must be > 0

elasticsearch.requestTimeout: 300000

Time in milliseconds for Elasticsearch to wait for responses from shards.

Set to 0 to disable.

elasticsearch.shardTimeout: 0

Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying

elasticsearch.startupTimeout: 5000

Set the path to where you would like the process id file to be created.

pid.file: /var/run/kibana.pid

If you would like to send the log output to a file you can set the path below.

logging.dest: stdout

Set this to true to suppress all logging output.

logging.silent: false

Set this to true to suppress all logging output except for error messages.

logging.quiet: false

Set this to true to log all events, including system usage information and all requests.

logging.verbose: false


(Joe Fleming) #7

Looks like you're using the 64-bit version of Kibana, is your system actually 64-bit? Sounds like maybe you need the 32-bit Linux build...

Running uname -a will probably give you some insight into which arch you're running on.


(Simroo) #8

Hello
Here is the output
$ uname -a
Linux netmanager 3.2.0-4-686-pae #1 SMP Debian 3.2.68-1+deb7u6 i686 GNU/Linux


(Simroo) #9

So i get that iam running the 64 bit version of Kibana and iam trying to uninstall Kibana but i cant seem to do it.
sudo apt-get purge kibana . E: Cant find the packge kibana. My debian box cant find the pkg Kibana.
Where is it placed ?


(Joe Fleming) #10

Yeah, so step one is running the 32 bit version instead, as you are on a 32 bit system.

How'd you install it in the first place? We don't have an apt install process as far as I know, so I'm not sure how Kibana ended up in /opt on your system. Perhaps you put it there by hand?

In any event, all you need to do to "uninstall" Kibana is simply remove the /opt/kibana path, it doesn't create files anywhere else.


(system) #11