Kibana shows blank page for large indices


#1

If I point Kibana to an ElasticSearch with small indices, Kibana loads right away. If I point Kibana to an ElasticSearch with large indices, I see this blank page. It's been 25 minutes and I still see the blank page.

Here's the large index:

health status index         uuid                   pri rep docs.count docs.deleted store.size pri.store.size
yellow open   concept       jS0SEd6NQmiR_y4eIG48fQ   5   1    4385390            0      1.3gb          1.3gb

Kibana output

Can I file a bug to show some sort of loading indicator?


(Lee Drengenberg) #2

It looks like you were on the Dev Tools page when you got the blank screen. Or were you somewhere else like Discover and the highlight on Dev Tools is just a symptom of the page not loading?

When you're on Discover page, Kibana does show a loading indicator while it has a request to Elasticsearch in progress. And it loads "hits" incrementally as they come in from different nodes (or shards).

Can you please check your Kibana and Elasticsearch logs to see if there's an error?

This is the latest Kibana 6.2.2 release, but the loading indicator (of some type) has been there since at least 4.x version. In this case it's the pink moving bar near the top of the screen.


#3

Hmm, I changed some configuration and I no longer see this problem. I think there was an issue with networking and/or firewalls. Thanks.


#4

Some additional details in case others find this helpful.

So usually when Kibana can't reach Elasticsearch, it shows "Elasticsearch plugin is red":

For some reason, I was getting a blank page instead:

The blank page is misleading; because I don't see "Elasticsearch plugin is red", I thought Elasticsearch connection was fine.

In the scenario where I got the blank page, the Elasticsearch IP was correct and port was wrong.

But when I start kibana on my desktop with "-e http://localhost:9201", where 9201 is the wrong Elasticsearch port, I don't get a blank page. I'm not sure why blank page is sometimes displayed -- probably something to do with networking settings.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.