Kibana:Unable to check for Kibana Index .kibana


I am trying to configure apache reverse proxy for Kibana. However, it shows the below error on launch of kibana. I am able to successfully launch kibana on 5601 port of the actual server, but it fails when accessed from proxy server. Any help is much appreciated.

Kibana version - 4.1.1
ES version - 1.7.0

Error: Unable to check for Kibana index ".kibana"
Error: Internal Server Error
    at respond (
    at checkRespForFailure (
    at wrappedErrback (
index.js?_b=7489:45927 es check
index.js?_b=7489:45927 config init
index.js?_b=7489:45923 complete in 301.57ms
index.js?_b=7489:45927 checkEsVersion
index.js?_b=7489:45923 complete in 122.49ms
index.js?_b=7489:45927 kibana index check Failed to load resource: the server responded with a status of 500 (Internal Server Error)
index.js?_b=7489:19337 Error: Unable to check for Kibana index ".kibana"
Error: Internal Server Error
    at respond (index.js?_b=7489:85288)
    at checkRespForFailure (index.js?_b=7489:85256)
    at index.js?_b=7489:83894
    at wrappedErrback (index.js?_b=7489:20902)

Please note that other indices are accessible, works, it only fails on .kibana index.

Kibana.yml -

# Kibana is served by a back end server. This controls which port to use.
port: 5601

# The host to bind the server to.
host: ""

# The Elasticsearch instance to use for all your queries.
elasticsearch_url: "http://localhost:9200"

# preserve_elasticsearch_host true will send the hostname specified in `elasticsearch`. If you set it to false,
# then the host you use to connect to *this* Kibana instance will be sent.
elasticsearch_preserve_host: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations
# and dashboards. It will create a new index if it doesn't already exist.
kibana_index: ".kibana"

# If your Elasticsearch is protected with basic auth, this is the user credentials
# used by the Kibana server to perform maintence on the kibana_index at statup. Your Kibana
# users will still need to authenticate with Elasticsearch (which is proxied thorugh
# the Kibana server)
# kibana_elasticsearch_username: user
# kibana_elasticsearch_password: pass

# If your Elasticsearch requires client certificate and key
# kibana_elasticsearch_client_crt: /path/to/your/client.crt
# kibana_elasticsearch_client_key: /path/to/your/client.key

# If you need to provide a CA certificate for your Elasticsarech instance, put
# the path of the pem file here.
# ca: /path/to/your/CA.pem

# The default application to load.
default_app_id: "discover"

# Time in milliseconds to wait for elasticsearch to respond to pings, defaults to
# request_timeout setting
# ping_timeout: 1500

# Time in milliseconds to wait for responses from the back end or elasticsearch.
# This must be > 0
request_timeout: 300000

# Time in milliseconds for Elasticsearch to wait for responses from shards.
# Set to 0 to disable.
shard_timeout: 0

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying
# startup_timeout: 5000

# Set to false to have a complete disregard for the validity of the SSL
# certificate.
verify_ssl: true

# SSL for outgoing requests from the Kibana Server (PEM formatted)
# ssl_key_file: /path/to/your/server.key
# ssl_cert_file: /path/to/your/server.crt

# Set the path to where you would like the process id file to be created.
# pid_file: /var/run/

# If you would like to send the log output to a file you can set the path below.
# This will also turn off the STDOUT log output.
# log_file: ./kibana.log

# Plugins that are included in the build, and no longer found in the plugins/ folder
 - plugins/dashboard/index
 - plugins/discover/index
 - plugins/doc/index
 - plugins/kibana/index
 - plugins/markdown_vis/index
 - plugins/metric_vis/index
 - plugins/settings/index
 - plugins/table_vis/index
 - plugins/vis_types/index
 - plugins/visualize/index
1 Like

Might help to post your Apache config here. There's no reason the Kibana index wouldn't be available. Maybe something in how you're securing the proxy? A bed regex? Tough to say. Does it work without the proxy?