Kibana Webservice Returns Blank Webpage?

Hi all,

I’ve recently brought up my first Kibana server, and it looks like the HTTP server is running but not actually sending any HTML…?

The details: My Kibana is the Docker container version, and I spun it us using this tutorial. The commands I specifically used to pull then spin up the container are:

docker pull docker.elastic.co/kibana/kibana:7.3.0

docker run --link MyElasticsearch:elasticsearch \
   -p 5601:5601 \
   --net mgt_network \
   --name MyKibana \
   -e ELASTICSEARCH_HOSTS="http://192.168.3.8:9200" \
   8bcee4a4f79d

...where...
-- "MyElasticsearch" is the Docker name of my Elasticsearch container, already running
-- ELASTICSEARCH_HOSTS is an environment variable that I think I have to set…? Not sure
-- "8bcee4a4f79d" is the Kibana docker image’s UUID

The Kibana container spins up fine and from it, I can ping my host machine, my Elasticsearch container, everywhere.

But then when point my browser to my Kibana on TCP 5601, I pull down a blank webpage. And when I test within the Kibana container itself, I also get a blank page. Check this out, this is me on the Kibana's command line:

bash-4.2$ curl localhost:5601 > /tmp/webpage
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
bash-4.2$ ls -l /tmp
total 8
-rw-r--r-- 1 kibana kibana    0 Aug  8 20:21 webpage
bash-4.2$

Soooo… The online documentation says that once I spin up Kibana, I should be able to websurf to my Kibana and start configuring it. But is there something else I have to do to spur the web service into action? Any suggestions on how to troubleshoot this?

Are there any log files which I should consult? Below are the “docker logs” output for my Kibana container, captured while I was trying to do sample websurfs to TCP 5601:

{"type":"log","@timestamp":"2019-08-08T20:12:59Z","tags":["listening","info"],"pid":1,"message":"Server running at http://0:5601"}
{"type":"log","@timestamp":"2019-08-08T20:12:59Z","tags":["info","http","server","Kibana"],"pid":1,"message":"http server running"}
{"type":"log","@timestamp":"2019-08-08T20:12:59Z","tags":["status","plugin:spaces@7.3.0","info"],"pid":1,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsarch"}
{"type":"response","@timestamp":"2019-08-08T20:13:35Z","tags":[],"pid":1,"method":"get","statusCode":302,"req":{"url":"/","method":"get","headers":{"user-agent":"curl/7.29.0","host":"localhost:5601","accept":"*/*"},"remoteAddress:"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":302,"responseTime":22,"contentLength":9},"message":"GET / 302 22ms - 9.0B"}
{"type":"response","@timestamp":"2019-08-08T20:21:29Z","tags":[],"pid":1,"method":"get","statusCode":302,"req":{"url":"/","method":"get","headers":{"user-agent":"curl/7.29.0","host":"localhost:5601","accept":"*/*"},"remoteAddress:"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":302,"responseTime":5,"contentLength":9},"message":"GET / 302 5ms - 9.0B"}
{"type":"response","@timestamp":"2019-08-08T20:21:45Z","tags":[],"pid":1,"method":"get","statusCode":302,"req":{"url":"/","method":"get","headers":{"user-agent":"curl/7.29.0","host":"localhost:5601","accept":"*/*"},"remoteAddress:"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":302,"responseTime":5,"contentLength":9},"message":"GET / 302 5ms - 9.0B"}
{"type":"log","@timestamp":"2019-08-08T20:25:15Z","tags":["info","plugins-system"],"pid":1,"message":"Stopping all plugins."}
{"type":"log","@timestamp":"2019-08-08T20:25:16Z","tags":["info","plugins","translations"],"pid":1,"message":"Stopping plugin"}
{"type":"log","@timestamp":"2019-08-08T20:27:12Z","tags":["info","plugins-system"],"pid":1,"message":"Setting up [1] plugins: [translations]"}
{"type":"log","@timestamp":"2019-08-08T20:27:12Z","tags":["info","plugins","translations"],"pid":1,"message":"Setting up plugin"}
{"type":"log","@timestamp":"2019-08-08T20:27:12Z","tags":["info","plugins-system"],"pid":1,"message":"Starting [1] plugins: [translations]"}
{"type":"log","@timestamp":"2019-08-08T20:27:37Z","tags":["info","plugins-system"],"pid":1,"message":"Setting up [1] plugins: [translations]"}
{"type":"log","@timestamp":"2019-08-08T20:27:37Z","tags":["info","plugins","translations"],"pid":1,"message":"Setting up plugin"}
{"type":"log","@timestamp":"2019-08-08T20:27:37Z","tags":["info","plugins-system"],"pid":1,"message":"Starting [1] plugins: [translations]"}

@redapplesonly have u seen if you are hitting any error in the browser's developer console?

Thanks Tiagocosta,

So I went to look at my Kibana server after seeing your note. Now the portal is available and there is no trouble surfing to it. Well, the response is pretty slow, but that's probably because the host system is overtaxed. Not sure why the Kibana portal was blank yesterday... but I'm not about to look a gift horse in the mouth. Thanks for the help :slight_smile: