Kibana with Shield SSL


(Harsh Jain) #1

Hello,
Trying to enable Kibana to work with Shield. I'm getting this error in the log:
FATAL { [Error: EACCES: permission denied, open '/etc/.../file.key

Similar to this thread:

Using Shield 4.6
Appreciate the help.

EDIT:
Solved it!
It seems that the documentation doesn't mention WHERE to put the .key and .crt for kibana.
I was using the directions on this page. https://www.elastic.co/guide/en/shield/current/kibana.html
Skipping step 5, I first went to step 6 and installed Shield in Kibana. THEN i moved the generated .key/.crt to the /opt/kibana/installedPlugins/shield/ directory. This solved the "Permission Denied" issue on the key.


(Tyler Smalley) #2

What are the permissions of file.key? ls -al /etc/.../file.key

How are you starting Kibana and as what user?


(Harsh Jain) #3

It has root permissions and I've tried a range of permissions from default to all rwx access. and I'm using sudo to start kibana.


(Harsh Jain) #4

Thanks Tyler.
You got me thinking about kibana not being able to access a directory so I moved the key/crt to within Kibana's directory. and that solved it. See Edit in my post.

Harsh


(system) #5