LDAP/AD auth for ECE

security

(Chad-Lee Witbooi) #1

Hi

Is there any docs regarding setting up LDAP or AD for elasticsearch cloud enterprise.

Regards
Chad


(Ioannis Kakavas) #2

Hi,

Are you looking for this ?


(Chad-Lee Witbooi) #3

Thanks Ioannis, I found that document yes just thought I would get a expert opinion as well


(Chad-Lee Witbooi) #4

Do I create a plugin?


(Ioannis Kakavas) #5

Apologies, but I'm not sure what you mean.

ECE supports LDAP for authentication. Did you go through the documentation? Is there something that is not clear or a specific step that you have issues with?


(Chad-Lee Witbooi) #6

never mind that question I just didn't know how to get started...Will I be able to enable xpack security with the trail version of ece?

Regards
Chad


(Chad-Lee Witbooi) #7

I just want to test LDAP/AD configuration


(Alex Piggott) #8

Hi @cwitbooi

never mind that question I just didn't know how to get started...Will I be able to enable xpack security with the trail version of ece?

Yes, the trial version is fully functional, just follow the instructions in the link @ikakavas posted, and create a thread here if you run into issues. (The main annoyance currently is that if you want to test certification you need to host the cert bundle on a web server that the ECE install can see - otherwise it's quite straightforward)

Alex


(Chad-Lee Witbooi) #9

Awesome thanks Alex...I ran into some issues yesterday will recreate and post here. I kind of figured that I need to host it in a webserver seeing that it needs a URL


(Chad-Lee Witbooi) #10


(Chad-Lee Witbooi) #11

Thats the message I get when I try to enable security xpack


(Chad-Lee Witbooi) #12

Okay I am trying to setup SAML auth in Kibana and Elastic bare in mind its Elasticsearch Cloud Enterprise (ECE), it is a SSO using keycloak


(Ioannis Kakavas) #13

Hi,

is there a question? Do you have any specific issue that you need assistance with ?


(Alex Piggott) #14

For some reason I thought I'd responded to this, apologies

Xpack is always enabled in ECE, it won't let you turn it off hence the error message, you don't need to set it