License Issue - Put Request returns null_pointer_exception


(Samuel Larsen Disney) #1

Whenever I try and place my License JSON I receive the following error:
{
"error": {
"root_cause": [
{
"type": "null_pointer_exception",
"reason": null
}
],
"type": "null_pointer_exception",
"reason": null
},
"status": 500
}

This happens if I try the PUT request both at http://localhost:9200/_license/ and http://localhost:9200/_xpack/license/
Elastisearch shows this:


(Samuel Larsen Disney) #2

Anyone?


(Christian Dahlqvist) #3

How are you updating the licence? Did you follow these instructions for your OS?


(Samuel Larsen Disney) #4

I tried to use the put request on windows. What is 'gc' if I try and run this within cmd or GIT bash I recieve a 'command not found'


(Samuel Larsen Disney) #5

After working out it meant powershell (Documentation should say that over just 'windows'), I am still having the same error.


(Tim Vernum) #6

It looks like something isn't quite right with your license file. The error you're seeing indicates that the license is mostly valid, but is missing a key field.

Are you willing to send me your license file in a private message? I'll see if I can understand what's happened.
Alternatively you might try re-downloading the license from our license portal.


(Samuel Larsen Disney) #7

I've sent you the license!


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.