Loading data using JDBC Importer To Found elastic Cluster


(Rajiv Kumar) #1

Hi All

I am trying to import data in the found elasticsearch remote instance using JDBC importer.

However I am getting below error on running JDBC importer script.

at org.xbib.elasticsearch.support.client.BaseTransportClient.createClient(BaseTransportClient.java:52) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.support.client.BaseIngestTransportClient.newClient(BaseIngestTransportClient.java:22) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.support.client.transport.BulkTransportClient.newClient(BulkTransportClient.java:88) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.jdbc.strategy.standard.StandardContext$1.create(StandardContext.java:440) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.jdbc.strategy.standard.StandardSink.beforeFetch(StandardSink.java:94) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.jdbc.strategy.standard.StandardContext.beforeFetch(StandardContext.java:207) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]
at org.xbib.elasticsearch.jdbc.strategy.standard.StandardContext.execute(StandardContext.java:188) ~[elasticsearch-jdbc-1.7.0.0-uberjar.jar:?]

My connection string looks as below:

"elasticsearch" : {
"cluster" : "XXXXXXeb56c80f986ead6XXXXXXXXXXXX",
"host" : "XXXXXXeb56c80f986ead6XXXXXXXXXXXX.region.aws.found.io",
"port" : 9343
}

Any help will be highly appreciated.


(Mark Walkom) #2

I'm moving this to the Elasticsearch area as it's not a supported plugin on Found unfortunately.
I'm sure the @jprante will stop by though :slight_smile:


(Rajiv Kumar) #3

Hope @jprante will have something on this.

Do you know the supported plugins on found for migration or if you could point me to some documentation. That will help!


(Jörg Prante) #4

I'm here for help. but you can also open an issue at JDBC importer https://github.com/jprante/elasticsearch-jdbc/issues

Have you declared the found transport including API key in the JDBC importer spec, like in this example?


(Rajiv Kumar) #5

Thanks for your help!!!

Sorry, I believe there are couple of things where I am confused and can't decide where to open which issue.

I am trying to use JDBC importer with shield as I believe found is discontinuing the ACL from 1st Dec, so there is no configuration for api Key available.

Also, I tried not to enable the shield however JDBC importer still not able to find any nodes. Kindly let me know if I have to open a issue as suggested, for adding support of shield in JDBC importer.


(Jörg Prante) #6

It is not possible to support Shield by JDBC importer, because Shield is closed source, sorry.


(system) #7