Local JVM node


(Mohit Anchlia) #1

I am trying to form a cluster between my test elasticsearch that runs in
jvm with my main code that connects using transportclient but it doesn't
seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get
node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0] timed out
after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #2

Just a guess, but perhaps creating a local node client does not instantiate
the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am trying to form a cluster between my test elasticsearch that runs in
jvm with my main code that connects using transportclient but it doesn't
seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200
]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get
node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0] timed
out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mohit Anchlia) #3

I do see process listening on port 9200 and also the logs seems to indicate
that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am trying to form a cluster between my test elasticsearch that runs in
jvm with my main code that connects using transportclient but it doesn't
seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200
]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get
node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0] timed
out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #4

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am trying to form a cluster between my test elasticsearch that runs
in jvm with my main code that connects using transportclient but it doesn't
seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get
node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0] timed
out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mohit Anchlia) #5

I see, is there a way to run embedded ES that allows me to connect using
TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am trying to form a cluster between my test elasticsearch that runs
in jvm with my main code that connects using transportclient but it doesn't
seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get
node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0]
timed out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #6

It appears that everything is running, but you simply might be using the
wrong ports.

In your code:
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

What value are you using for the port? 9200 or 9300? Make sure it is 9300.

On Tue, Mar 18, 2014 at 3:37 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I see, is there a way to run embedded ES that allows me to connect using
TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am trying to form a cluster between my test elasticsearch that
runs in jvm with my main code that connects using transportclient but it
doesn't seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to
get node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0]
timed out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDx4BQ%3DRhU81-7HWpXKwYGxdaE0yJq9S4pJTLQrcenZxQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #7

Also, you should see something along the lines of

bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
192.168.52.162:9300]}

Note the 9300

On Tue, Mar 18, 2014 at 3:44 PM, Ivan Brusic ivan@brusic.com wrote:

It appears that everything is running, but you simply might be using the
wrong ports.

In your code:
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

What value are you using for the port? 9200 or 9300? Make sure it is 9300.

On Tue, Mar 18, 2014 at 3:37 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I see, is there a way to run embedded ES that allows me to connect using
TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia <mohitanchlia@gmail.com

wrote:

I am trying to form a cluster between my test elasticsearch that
runs in jvm with my main code that connects using transportclient but it
doesn't seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to
get node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0]
timed out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mohit Anchlia) #8

I am not seeing anything come up on port 9300.

this is the log that shows only port 9200

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] version[1.0.0],
pid[11624], build[a46900e/2014-02-12T16:18:34Z]

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initializing ...

INFO org.elasticsearch.plugins [Thread-0]: [Agent Zero] loaded [], sites []

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initialized

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] starting ...

INFO org.elasticsearch.transport [Thread-0]: [Agent Zero] bound_address
{local[1]}, publish_address {local[1]}

INFO org.elasticsearch.cluster.service [elasticsearch[Agent
Zero][clusterService#updateTask][T#1]]: [Agent Zero] new_master [Agent
Zero][CDptnrekR-yL5eH91y7Yiw][SDGL0770E674E03][local[1]]{local=true},
reason: local-disco-initial_connect(master)

INFO org.elasticsearch.discovery [Thread-0]: [Agent Zero]
elasticsearch/CDptnrekR-yL5eH91y7Yiw

INFO org.elasticsearch.http [Thread-0]: [Agent Zero] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200]}

INFO org.elasticsearch.gateway [elasticsearch[Agent
Zero][clusterService#updateTask][T#1]]: [Agent Zero] recovered [1] indices
into cluster_state

On Tue, Mar 18, 2014 at 3:45 PM, Ivan Brusic ivan@brusic.com wrote:

Also, you should see something along the lines of

bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
192.168.52.162:9300]}

Note the 9300

On Tue, Mar 18, 2014 at 3:44 PM, Ivan Brusic ivan@brusic.com wrote:

It appears that everything is running, but you simply might be using the
wrong ports.

In your code:
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

What value are you using for the port? 9200 or 9300? Make sure it is
9300.

On Tue, Mar 18, 2014 at 3:37 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I see, is there a way to run embedded ES that allows me to connect using
TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia <
mohitanchlia@gmail.com> wrote:

I am trying to form a cluster between my test elasticsearch that
runs in jvm with my main code that connects using transportclient but it
doesn't seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to
get node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0]
timed out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWp18uN%3DVEds0meHmGAZ7%2B%3Dvb9vK%2BjzozOsfokgr4A9CTQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mohit Anchlia) #9

I removed local(true) from the builder call and it seem to come up on 9300
now

On Tue, Mar 18, 2014 at 3:55 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I am not seeing anything come up on port 9300.

this is the log that shows only port 9200

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] version[1.0.0],
pid[11624], build[a46900e/2014-02-12T16:18:34Z]

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initializing ...

INFO org.elasticsearch.plugins [Thread-0]: [Agent Zero] loaded [], sites []

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initialized

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] starting ...

INFO org.elasticsearch.transport [Thread-0]: [Agent Zero] bound_address
{local[1]}, publish_address {local[1]}

INFO org.elasticsearch.cluster.service [elasticsearch[Agent
Zero][clusterService#updateTask][T#1]]: [Agent Zero] new_master [Agent
Zero][CDptnrekR-yL5eH91y7Yiw][SDGL0770E674E03][local[1]]{local=true},
reason: local-disco-initial_connect(master)

INFO org.elasticsearch.discovery [Thread-0]: [Agent Zero]
elasticsearch/CDptnrekR-yL5eH91y7Yiw

INFO org.elasticsearch.http [Thread-0]: [Agent Zero] bound_address
{inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200
]}

INFO org.elasticsearch.gateway [elasticsearch[Agent
Zero][clusterService#updateTask][T#1]]: [Agent Zero] recovered [1] indices
into cluster_state

On Tue, Mar 18, 2014 at 3:45 PM, Ivan Brusic ivan@brusic.com wrote:

Also, you should see something along the lines of

bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/
192.168.52.162:9300]}

Note the 9300

On Tue, Mar 18, 2014 at 3:44 PM, Ivan Brusic ivan@brusic.com wrote:

It appears that everything is running, but you simply might be using the
wrong ports.

In your code:
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

What value are you using for the port? 9200 or 9300? Make sure it is
9300.

On Tue, Mar 18, 2014 at 3:37 PM, Mohit Anchlia mohitanchlia@gmail.comwrote:

I see, is there a way to run embedded ES that allows me to connect
using TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:

TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST
traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia <mohitanchlia@gmail.com

wrote:

I do see process listening on port 9200 and also the logs seems to
indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:

Just a guess, but perhaps creating a local node client does not
instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia <
mohitanchlia@gmail.com> wrote:

I am trying to form a cluster between my test elasticsearch that
runs in jvm with my main code that connects using transportclient but it
doesn't seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent]
bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/
172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host,
port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to
get node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]],
disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException:
[][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0]
timed out after [5002ms]
at
org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown
Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown
Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpX4tFYR%2BX_Mw8TRKvAB3PJH%3D-HJ%2BGS83vQBJDNSBaAzQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #10

May be this could help you: https://github.com/elasticsearch/elasticsearch/blob/master/src/test/java/org/elasticsearch/test/TestCluster.java#L632

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 19 mars 2014 à 01:10, Mohit Anchlia mohitanchlia@gmail.com a écrit :

I removed local(true) from the builder call and it seem to come up on 9300 now

On Tue, Mar 18, 2014 at 3:55 PM, Mohit Anchlia mohitanchlia@gmail.com wrote:
I am not seeing anything come up on port 9300.

this is the log that shows only port 9200

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] version[1.0.0], pid[11624], build[a46900e/2014-02-12T16:18:34Z]

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initializing ...

INFO org.elasticsearch.plugins [Thread-0]: [Agent Zero] loaded [], sites []

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] initialized

INFO org.elasticsearch.node [Thread-0]: [Agent Zero] starting ...

INFO org.elasticsearch.transport [Thread-0]: [Agent Zero] bound_address {local[1]}, publish_address {local[1]}

INFO org.elasticsearch.cluster.service [elasticsearch[Agent Zero][clusterService#updateTask][T#1]]: [Agent Zero] new_master [Agent Zero][CDptnrekR-yL5eH91y7Yiw][SDGL0770E674E03][local[1]]{local=true}, reason: local-disco-initial_connect(master)

INFO org.elasticsearch.discovery [Thread-0]: [Agent Zero] elasticsearch/CDptnrekR-yL5eH91y7Yiw

INFO org.elasticsearch.http [Thread-0]: [Agent Zero] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200]}

INFO org.elasticsearch.gateway [elasticsearch[Agent Zero][clusterService#updateTask][T#1]]: [Agent Zero] recovered [1] indices into cluster_state

On Tue, Mar 18, 2014 at 3:45 PM, Ivan Brusic ivan@brusic.com wrote:
Also, you should see something along the lines of

bound_address {inet[/0:0:0:0:0:0:0:0:9300]}, publish_address {inet[/192.168.52.162:9300]}

Note the 9300

On Tue, Mar 18, 2014 at 3:44 PM, Ivan Brusic ivan@brusic.com wrote:
It appears that everything is running, but you simply might be using the wrong ports.

In your code:
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

What value are you using for the port? 9200 or 9300? Make sure it is 9300.

On Tue, Mar 18, 2014 at 3:37 PM, Mohit Anchlia mohitanchlia@gmail.com wrote:
I see, is there a way to run embedded ES that allows me to connect using TransportClient?

On Tue, Mar 18, 2014 at 3:32 PM, Ivan Brusic ivan@brusic.com wrote:
TransportClient uses port 9300 by default. Port 9200 is for HTTP/REST traffic.

--
Ivan

On Tue, Mar 18, 2014 at 3:30 PM, Mohit Anchlia mohitanchlia@gmail.com wrote:
I do see process listening on port 9200 and also the logs seems to indicate that it's connected on that port

On Tue, Mar 18, 2014 at 3:21 PM, Ivan Brusic ivan@brusic.com wrote:
Just a guess, but perhaps creating a local node client does not instantiate the internal Jetty server.

--
Ivan

On Tue, Mar 18, 2014 at 2:55 PM, Mohit Anchlia mohitanchlia@gmail.com wrote:
I am trying to form a cluster between my test elasticsearch that runs in jvm with my main code that connects using transportclient but it doesn't seem to work:

My test class code:

node = nodeBuilder().local(true).node();
client = node.client();

// This connects fine
INFO org.elasticsearch.http [Thread-0]: [Midgard Serpent] bound_address {inet[/0:0:0:0:0:0:0:0:9200]}, publish_address {inet[/172.28.172.154:9200]}

// Now the transport client code
client = new TransportClient()
.addTransportAddress(new InetSocketTransportAddress(host, port));

// This fails to connect to the one I started in local(true) mode:
INFO org.elasticsearch.client.transport [main]: [Oracle] failed to get node info for [#transport#-1][SDGL0][inet[/172.28.172.154:9200]], disconnecting...
org.elasticsearch.transport.ReceiveTimeoutTransportException: [][inet[/172.28.172.154:9200]][cluster/nodes/info] request_id [0] timed out after [5002ms]
at org.elasticsearch.transport.TransportService$TimeoutHandler.run(TransportService.java:356)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWoht0_gzj-GRkAO2xcvAqDfZ%3Djz-xCUPWvozLnKbfKbtQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQBfGFKJ5tQfwO%2Br2%2B58kKea-LDLvtoRN6Uts9Auh4SeQg%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpGfA5JLYghAjOhWPOLdZDeM59x5WW2wS6YKCvDUYwScg%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCJx2_mVh2fch6jAgGKb%3DrORiamfbHTtNUuAGzi2qZh8w%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpHzQxzD16XtoiDibBQ%2B%3DpvbyZZ7g4CiLCSaa_iKLtU%3DA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDgnMfkW%2B3-PscYM0pT3dq8rmgNTFzC5k6E6K460BGkWw%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAOT3TWpX4tFYR%2BX_Mw8TRKvAB3PJH%3D-HJ%2BGS83vQBJDNSBaAzQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/338BF46C-CEFB-4CE3-B3E8-63533963B44D%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #11