Login failed on GUI of service.bat

Hey guys,
I have a problem to login over service.bat with a specific account.
The only thing I see the service doesn't start. And it isn't nothing logged in the Elasticsearch logs.
What can I do. Please help me!


May be this user does not have rights to read/write in elasticsearch config/data dirs?

I have rights to read and write

Is it the same for D:\elasticsearch-2.3.2_Node2 dir?
BTW why Node2? Are you trying to install more than one node as a service on your machine?

Yes it is the same for D:\elasticsearch-2.3.2_Node2 dir.
And on this machine there is running a second instance of elasticsearch but this instance works with standard system user.

So why do you want to start another service?

Ok. For your comprehension I explain the whole context of my doing and what is our aim. We use the Robotic Process Automation tool Uipath and it writes Logging Information in Elasticsearch. The nodes are on the machine where the robots run. When this machine goes down, the robots doen't work so it is not bad when the elasticsearch logging does not work at this moment.
We have one master node which is also a data node. And we have a second node which is only for holding data it holds replica of the master node. This node cannot be a master node. We want to write/transfer the information in the elasticsearch data folder to a share folder. Our problem is now that we cannot give all read and write rights to all user for data folders on machine which is the share folder. We need an explicit account. So therfore I try to use a specific account over the service.bat gui. But this small and essential step fails when I start the elasticsearch service.

But why? You don't need to do that. You just need to have one single node on your machine.

Use Snapshot/Restore for that.

Ok. I find your idea very helpful. Instead to copy data to a share folder I make a snapshot of my data to this share folder. But the main problem is still there. I create a sharefolder on another machine. The Filepath for example \server_name\IA_SHARE\Snapshots and in elasticsearch.yml is standing path.repo: ["\\server_name\IA_SHARE\Snapshots"] but when I run elasticsearch elasticsearch stops immediateley. I create a share folder on the system where elasticsearch run. This works fine and elasticsearch is running and I can create snapshots of my dates there.

Probably because you need to write it as ["\\\\server_name\\IA_SHARE\\Snapshots"] instead?

changed but same behaviour :frowning:

Can you share settings and logs ?

elasticsearch log:

[2017-04-03 11:51:53,246][ERROR][bootstrap                ] Exception
java.lang.IllegalStateException: Unable to access 'path.repo' (\\server_name\IA_SHARE\Snapshots)
    at org.elasticsearch.bootstrap.Security.addPath(Security.java:316)
    at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:262)
    at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:212)
    at org.elasticsearch.bootstrap.Security.configure(Security.java:118)
    at org.elasticsearch.bootstrap.Bootstrap.setupSecurity(Bootstrap.java:196)
    at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:167)
    at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:270)
    at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
Caused by: java.nio.file.FileSystemException: \\server_name\IA_SHARE\: The filename, directory name, or volume label syntax is incorrect.

    at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:86)
    at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)
    at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)
    at sun.nio.fs.WindowsFileSystemProvider.checkReadAccess(WindowsFileSystemProvider.java:338)
    at sun.nio.fs.WindowsFileSystemProvider.checkAccess(WindowsFileSystemProvider.java:362)
    at java.nio.file.Files.createDirectories(Files.java:746)
    at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:337)
    at org.elasticsearch.bootstrap.Security.addPath(Security.java:314)
    ... 7 more

elasticsearch yml file

cluster.name: elasticsearch
node.name: UipathMasterNode
node.master: true
node.data: true
index.number_of_replicas: 1
path.data: D:\elasticsearch-2.3.2\data
path.repo: ["\\\\server_name\\IA_SHARE\\Snapshots"]
path.logs: D:\elasticsearch-2.3.2\logs
discovery.zen.ping.unicast.hosts: [""]
discovery.zen.minimum_master_nodes: 1

Can you try with //server_name/IA_SHARE/Snapshots?

Is this directory accessible for the user who is running elasticsearch on your machine.

I tried your suggestion, same error message.
This directory is accessible for the user who is running elasticsearch on my machine!
Is there any possibility to make a websession?

No sorry.

May be @abeyad would know?

Is it a Windows file share? I'm not sure what the correct format would be. What are you using to host the snapshots? I would consult its documentation to see what the format should be for specifying the file share.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.