Logs are not showing up

Hi, I have configured filebeats file to send logs to elastic but my logs are showing up in index or logs page I have tried creating the file and new system 3 time by now can someone please help me getting the logs.

Hope you are following this setup
https://www.elastic.co/guide/en/beats/filebeat/7.2/filebeat-getting-started.html

Yes i am following it thoroughly. As I have already mentioned i have tried same process thrice.

Please show us your filebeat.yml configuration file

What is the output of command

$ filebeat test output

Sorry for the late reply I was caught up in some work.

So in the config rather than making a lot of changes I have only added the cloud.id and cloud.auth in the place where they are. Showing the file would be complicated as there are quite a lot of comments.

The output of the test is all files are Ok

elasticsearch: https://b1498a0a68c64b39919a0f06422f76b1.asia-northeast1.gcp.cloud.es.io:9243...
parse url... OK
connection...
parse host... OK
dns lookup... OK
addresses: 35.221.101.61
dial up... OK
TLS...
security: server's certificate chain verification is enabled
handshake... OK
TLS version: TLSv1.2
dial up... OK
talk to server... OK
version: 7.3.0