Logstash 2.1.1 Fresh ELK Install Errors


(Ninjada) #1

Hi Guys,

Presently updating my ELK stack a few versions behind to new servers running the latest versions.

At first I got some error:

you might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with lock_jars command

no such file to load -- org/apache/httpcomponents/httpclient/4.5/httpclient-4.5 (LoadError)

Theres another thread: Logstash 2.1 fails to start after logstash-output-elasticsearch update -- with some suggestions which I tried amongst other things but that did not fix the problem for me...

I deployed everything from scratch again without running '/opt/logstash/bin/plugin update' and the above error is gone but i get the following error upon starting logstash:

:timestamp=>"2016-01-05T15:58:34.881000+1100", :message=>"Connection refused", :class=>"Manticore::SocketException", :level=>:error}

It doesn't appeared to have stopped things, as logs start ingesting ok as far as I can tell.. but I'm just wondering what it relates to and whats happening etc... so I can get rid of this error. Hadn't had an issue with Manticore previously.

Cheers!


(Magnus B├Ąck) #2

The latter error messages suggests that you've configured Logstash (probably the elasticsearch output) to connect to a port where nothing was listening, at least not at the time. Perhaps you started Logstash before Elasticsearch had started up completely?


(Ninjada) #3

ah yep looks like it was just temporary, hasn't appeared again!


(system) #4