Logstash 2.2.2 Not reading file input

New to logstash. I am trying to read a simple input and output it to command window.

Logstash version: 2.2.2

Below is my .conf file

input {
file {
path => "/home/pdutt/CollPoll/Data/logstash-test-data.log"
start_position => "beginning"
sincedb_path => "/dev/null"

output {

Below is my logstash-test-data.log

This is the output I get after --debug and --verbose

$ logstash -f logstash-test.conf --debug --verbose
Settings: Default pipeline workers: 4
Registering file input {:path=>["/home/pdutt/CollPoll/Data/logstash-test-data.log"], :level=>:info}
Starting pipeline {:id=>"base", :pipeline_workers=>4, :batch_size=>125, :batch_delay=>5, :max_inflight=>500, :level=>:info}
Pipeline started {:level=>:info}
Logstash startup completed

And then nothing happens. I'm expecting the log to be displayed on the terminal.

For a single line you are better off using stdin and then just pasting the line in.

What are you trying to achieve with this method?

Here I am just testing the input-file plugin. I have tried using stdin and that works as expected. But it should also work using file input right? I feel like logstash is unable to read the input file.

I was seeing something similar also. It seemed like sometimes it would load the file, but sometimes it wouldn't. I ended up just using stdin for testing and doing one line at a time. Our production environment doesn't use the file input so it's easy enough for us to just avoid it.

It is sitting there waiting for an CRLF. Re-open the file with an editor and press Enter/Return to start a new line. If your test case had multiple lines it would have worked.