Logstash 5.0.0-alpha5: kafka not found


after upgrading 5.0.0-alpha4 to 5 using logstash-rpm I get the error:

  /usr/share/logstash/bin/logstash --path.settings=/etc/logstash -t --log.level debug -e 'output { kafka { topic_id => "logstash" }}'

--- jar coordinate com.fasterxml.jackson.core:jackson-annotations already loaded with version 2.7.1 - omit version 2.7.0
--- jar coordinate com.fasterxml.jackson.core:jackson-databind already loaded with version 2.7.1 - omit version 2.7.1-1
Sending logstash logs to /var/log/logstash/logstash.log.

The given configuration is invalid. Reason: Couldn't find any output plugin named 'kafka'. Are you sure this is correct? Trying to load the kafka output plugin resulted in this error: Problems loading the requested plugin named kafka of type output. {:level=>:fatal, :file=>"logstash/runner.rb", :line=>"216", :method=>"execute"}

The same error occurs for logstash-input-kafka

you need use :
bin/plugin install --version 5.0.0 logstash-input-kafka
bin/plugin install --version 5.0.0 logstash-output-kafka

Kafka is an elastic plugin and should work out of the box.
Tried several install/remove/diff but did not succeed.
Downgraded to alpha4, now its working again.
Wait for beta1.

Same here

I'm having this problem too

Try version 5.0.4 https://rubygems.org/gems/logstash-input-kafka

I've the same issue. See https://github.com/elastic/logstash/issues/5777 for the workaround.