Logstash 5.6 Date filter target setting not working


(Albert Stark) #1

We have a date field filebeat_timestamp that has the dates in the following format: 2018-01-11T21:50:50.219Z.

We want to convert the date to this format: January 11 2018, 16:50:50.219 . We want to make sure that we remove the GMT.

We are using the following code. The target field never creates filebeat_timestamp_2. We tried placing filebeat_timestamp as the target and that did not work either.

date {
match => [ "filebeat_timestamp", "MMMM dd yyyy HH:mm:ss.SSSZZZ" ]
target => "filebeat_timestamp_2"
}


(Magnus B├Ąck) #2

The date pattern in the match option describes the date format of the field that's being read (filebeat_timestamp in this case) so that it can be correctly parsed. It's not a way to configure the format of the date written to the field in the target option. The output format of the date filter isn't configurable.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.