Logstash 6.4 having errors during start


#1

Hello,

I installed logstash 6.4 and I am seeing this error:

It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.

I installed libyaml and I didn't even have ruby installed, so I installed that, but logstash still threw these errors after installation of ruby and libyaml. I also tried reinstalling logstash after installing both of these, but still have the same error.

Please help


#2

Check that you have not run out of disk space in opt. The default location where logstash creates temp jruby<logstash_pid>, usually under /opt/logstash/

With the introduction of Elastic v5 on, for each running logstash process an associated sub folder is created in /opt/logstash/jruby-xxxx. The xxxx is the PID of the running logstash, the folder contains a set of JAR files which are referenced by the instantiated logstash process.

When the logstash process is stopped or restarted gracefully the /opt/logstash/jruby-xxxx folder is removed. If for some reason the logstash process is stopped abnormally, this includes using kill -9, the folder will persist on disk. Overtime these folders can build up and consume disk space. Thus preventing any logstash from starting up, the error complains about dependent files missing and re-install of ruby.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.