Logstash 7.0.0 File Input on windows 10 issue

Hello folks,

This looks like the same old issue of logstash on windows. Input file is not being picked up and doesn't give out anything on console output. I've checked various posts on this and tried most of the solutions of "path with forward slashes", "ignore_older" and so on but nothing works.

OS. Windows 10 Pro. 64 bit.
Logstash ver. 7.0.0 & 6.6.1 (tried to run this on both the versions)
Powershell in Administrative Mode.

Command from powershell.
./logstash -f "E:\logstash-configs\logstash-simple.conf"


   input {
    	file {
    		path => "E:/logstash-test/d1.csv"
    		start_position => "beginning"
    		sincedb_path => "NUL"

    filter {
    	csv {
    		separator => ","
    		columns => ["open","high","low"]

    output {
    	stdout { codec => rubydebug }

d1.csv file

Logstash log from debug info

I suggest you run with --log.level debug and see what filewatch has to say.

I too have the same issue

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.