Logstash 7.1.1 - java memory settings not applied

Hi,

I have a docker-compose file like this,

version: "3.4"
services:
  logstash:
    build:
      context: .
    volumes:
      - /opt/elk-logstash/conf/pipeline:/usr/share/logstash/pipeline/
      - /opt/elk-logstash/conf/ssl:/usr/share/logstash/conf/ssl
      - /opt/elk-logstash/conf/logstash.yml:/usr/share/logstash/config/logstash.yml
    ports:
      - "5044:5044"
    environment:
      LS_JAVA_OPTS: "-Xmx3584m -Xms3584m"
    restart: always

And a Dockerfile like this,

FROM docker.elastic.co/logstash/logstash:7.1.1

LS_JAVA_OPTS of 3548m isn't applied,
within the docker container it has applied a default 1g setting,

bash-4.2$ ps -eo args
COMMAND
/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djruby.co
bash

Isn't LS_JAVA_OPTS the env var to change java memory settings?