Logstash as service restarts every 30sec, also doesnt log


(Alexander Kasper) #1

Hey,

I was trying out different things with logstash while starting it from command line using
sudo /usr/share/logstash/bin/logstash -f /etc/logstash/conf.d/config.conf

Everything worked fine there. I would like to use logstash as a service in the long term.
When no logs showed up I looked up the status using
sudo service logstash status
I noticed that logstash was restarting every 30s because of the line:
Active: active (running) since .....; 15s ago
The time at the end of the line never exceed 30s.

When I tried to look at the logstash logs I noticed that "ls /var/log/logstash" returns absolutely nothing even though I have "path.logs: /var/log/logstash" in my logstash.yml

Any ideas would be appreciated,
Alex


(Jymit Singh Khondhu) #2

What version of Logstash is at play here?
It has been found that debug logging goes a long way in getting more out the Logstash logging.


(Alexander Kasper) #3

Im using logstash 6.1.2-1

Are you talking about the (debug) logging level? I think I need to find out, why logstash is seemingly not writing any logs at all first.


(Jymit Singh Khondhu) #4

If not seen already and in aid here: https://www.elastic.co/guide/en/logstash/current/logging.html


(Peter Boer) #5

This error can be the result of a plugin not working correctly. List your installed plugins with
sudo bin/logstash-plugin list
and if needed remove them with
sudo bin/logstash-plugin remove [pluginname]


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.