Logstash Codec and other


(Carlos Magalhaes) #1

Hi there,

Just upgraded to 6.5.0 - what was upgraded -> ELK
I was checking the bin/logstash-plugin list and noticed some missing plugins which I use:

  1. Sflow
  2. Multiline

Did these get removed in 6.5.0 or did they get renamed to something else.
Checking my logs for logstash I noticed it is throwing an error for the Multiline plugin and my Sflow dashboards etc have no info so I thought I would check the plugins and see them missing?

Would appreciate the guidance.


(Carlos Magalhaes) #2

Update - seems like I had to reinstall logstash-codec-sflow.
Also had to reinstall logstash-codec-multiline.

Now sflow works -
Tried a reboot of the server as for some reason logstash even after a systemctl restart logstash wasnt loading the plugins:

Logs still show

[2018-11-19T14:27:37,672][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. 
{:exception=>#<LoadError: no such file to load -- logstash/filters/multiline>, 
:path=>"logstash/filters/multiline", :type=>"filter", :name=>"multiline"}
 [2018-11-19T14:27:37,674][ERROR][logstash.agent           ] Failed to execute action 
{:action=>LogStash::PipelineAction::Create/pipeline_id:main, 
:exception=>"LogStash::PluginLoadingError", :message=>"Couldn't find any filter plugin named 
'multiline'. Are you sure this is correct? Trying to load the multiline filter plugin resulted in this error: 
 no 
such file to load -- logstash/filters/multiline", :backtrace=>["/usr/share/logstash/logstash- 
core/lib/logstash/plugins/registry.rb:211:in `lookup_pipeline_plugin'", "/usr/share/logstash/logstash- 
core/lib/logstash/plugin.rb:137:in `lookup'", "org/logstash/plugins/PluginFactoryExt.java:210:in 
`plugin'", 
 "org/logstash/plugins/PluginFactoryExt.java:166:in `plugin'", "/usr/share/logstash/logstash- 
  core/lib/logstash/pipeline.rb:71:in `plugin'", "(eval):592:in `<eval>'", "org/jruby/RubyKernel.java:994:in 
  `eval'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:49:in `initialize'", 
"/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in `initialize'", 
"/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:42:in `block in execute'", 
"/usr/share/logstash/logstash-core/lib/logstash/agent.rb:92:in `block in exclusive'", 
"org/jruby/ext/thread/Mutex.java:148:in `synchronize'", "/usr/share/logstash/logstash- 
core/lib/logstash/agent.rb:92:in `exclusive'", "/usr/share/logstash/logstash- 
core/lib/logstash/pipeline_action/create.rb:38:in `execute'", "/usr/share/logstash/logstash- 
core/lib/logstash/agent.rb:317:in `block in converge_state'"]}

I am now trying a pluging remove and will try to reinstall it.