Logstash Configuration of 5.0.1


(Sharon Sasporta) #1

After upgrading logstash to 5.0.1 , I am getting the following :

WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. 

The configuration in startup.options is:

# Override Java location
JAVACMD=/usr/bin/java

# Set a home directory
LS_HOME=/usr/share/logstash

The files do exist in /etc/logstash

mpswrk1@eaasrt!MPS:/etc/logstash> ll
total 44
-rw-rw-r--    1 root root  1659 Nov 12 00:28 startup.options
-rw-rw-r--    1 root root  1333 Nov 12 00:28 **log4j2.properties**
-rw-rw-r--    1 root root  1738 Nov 12 00:28 jvm.options
drwxrwxr-x    2 root root  4096 Nov 12 00:28 conf.d
drwxr-xr-x. 108 root root 12288 Dec 11 17:58 ..
-rw-rw-r--    1 root root  2829 Dec 11 17:58 **logstash.yml**
-rwxr-xr-x    1 root root  6297 Dec 13 15:44 patterns
drwxr-xr-x    3 root root  4096 Dec 13 15:44 .

So, what do I miss here? How should I fix it?

Regards
Sharon.


WARNING: Could not find logstash.yml
(Mark Walkom) #2

When do you get that?


(Sharon Sasporta) #3

I am getting it when the logstash is booting up on the standard output.


(Mark Walkom) #4

Then you can ignore it.


(Nick Erber) #5

When starting with bin/logstash logstash is searching for the file in $LS_HOME/config by default. In your case, there aren't these files (because they are in the /etc/logstash directory).
If you really want this warning to not appear, the simplest way is to create a symlink
config -> /etc/logstash/


(Sharon Sasporta) #6

Yes, Solved !!! Thanks


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.